Users on 32-bit operating systems have reported problems with installing the Battlelog web plugin and using Google Chrome. We're working to have this issue resolved before the end of the week. Affected users are encouraged to temporarily use another web browser.

Stinger glitch

IxeLLe
AU Enlisted: 2012-09-28
2012-12-06 15:18
campaign rock and Hard Kill, there's is a time when i have to find the stinger in the wreck and take down the jet, but when i go where the arrow is pointing stinger, it wasn't there?! I tried restarting the mission several times but its still the same, i tried finding solutions but all of the solutions are for XBox 360, not for PC
spike9327
US Enlisted: 2012-12-01
2012-12-06 16:53
Its like that since the new update the other day. Its doing it on pc also. I googleed it and lots of people are having the same prob. Hopefully they will fix the glitch soon. Who do we need to talk to?
RoyalKing91
Enlisted: 2011-12-26
2012-12-19 23:16
Does anybody know how to fix the glitch for mission "Rock and a Hard place", I cant seem to find the stinger to take down the jet
Baker2444
Enlisted: 2012-12-18
2012-12-20 01:31 , edited 2012-12-20 01:31 by Baker2444
U got to delete the 5th multi player update. But i don't know how to. Thats y i'm still on that mission
RoyalKing91
Enlisted: 2011-12-26
2012-12-23 07:47
i just recently re-install the whole game and deleted all the previous mods that i had from the previous one and when i restarted the game i found the stinger you should try it