Not Full Screen

RevengerTT
GB Enlisted: 2011-10-27
2011-10-28 22:36
same issue here too
C_Menz
Enlisted: 2011-10-24
2011-10-28 22:38
You need to go into settings(press esc) and under video select your monitor's correct resolution. Then hit "apply fullscreen resolution". Alt+enter only toggles to and from fullscreen but only to the set resolution.
nowakl
PL Enlisted: 2011-10-25
2011-10-29 00:27 , edited 2011-10-29 00:34 by nowakl
@C-Menz - If the solution would be that obvious, I wouldn't bother anybody. Actually, that's first thing I've tried to do and unfortunately it doesn't work (at least with my system/resolution). If I set correct resolution and fullscreen option to "yes", the screen still flickers and after a while I have to minimize/maximize game window anyway. I've also tried the solution with TeamViewer, which was mentioned on some forums but as I can see, that doesn't matter in that case. Any new ideas?

@cyzlak - Probably you should just set fullscreen mode to "no" and then maximize game window. You can make this even easier and turn at "Control Panel" auto-hiding of system's taskbar/dock to "on".
wuckalooka
Enlisted: 2011-10-25
2011-10-29 00:30
Get on task manager, if you have Teamviewer running, disable all teamviewer instances.
nowakl
PL Enlisted: 2011-10-25
2011-10-29 00:44 , edited 2011-10-29 00:55 by nowakl
@wuckalooka - I've temporary disabled appropiate service at system's "Adminsitrative Tools" and then added an exclusion to TeamViewer's QuickConnect option - without any results.

Do have any of you, encountering that problem, a Teamviewer (v6) installed? I've also read on some forums about problems with Origin's and BF3's language compatibility, but apparently It should be manifested by problems with HUD and menu - these don't happen to me.
wuckalooka
Enlisted: 2011-10-25
2011-10-29 01:03
sorry, I meant disable it under processes. Try uninstalling Teamviewer and see if thats the reason why the game wont let you go on full screen, that was the culprit on my part.
nowakl
PL Enlisted: 2011-10-25
2011-10-29 09:48
Nope, uninstallation of TeamViewer doesn't work for me. When I've finally entered fullscreen mode after doing some different combinations in settings, I've noticed that I can't click on any button, while navigation by keyboard still works fine in menu. But then, when I try to enter main menu by keyboard, accepting the changed gfx settings (which seem to be correct), nothing shows up, except main menu's background.
Zorrus_88
ES Enlisted: 2011-10-27
2011-10-29 11:39
Same Problem here with the same laptop
aiuwdgba8pwd
US Enlisted: 2011-10-25
2011-10-29 12:39
You have to press CTRL + W while you are looking at your battlelog that will let the game know before hand that it needs to be in full screen.
nowakl
PL Enlisted: 2011-10-25
2011-10-29 15:59 , edited 2011-10-29 16:32 by nowakl
Maybe when AMD/ATI will release new driver (Catalyst 11.10) something will change, but for now the date of final realease is unknown. The most recent version is "Preview 3" and you can find it at http://support.amd.com/us/kbarticles/Pages/GPU124AMDCat1110PreDriverV3.aspx. [support.amd.com] Just in case: remember, that by installing preview drivers you can damage your system and you're doing it only on your own risk.

Some features mentioned at the time of first preview's release:
"With today's launch of the Battlefield 3 early beta, AMD has released a preview build of their Catalyst 11.10 drivers specifically for Battlefield 3. The Catalyst 11.10 Preview driver improves BF3 performance on the Radeon HD 5000 and 6000 series for both single-GPU and CrossFire configurations, and adds support for 5x1 Eyefinity."

However, I don't know if it'll also include some improvements for Radeon HD 5xxxM/6xxxM..

Which cards do you use - ATI/AMD or any different? On which system do you work - x86 or x64? Which version of drivers do you use?

Ps. Yesterday I've noticed that the game crashes when I try to set gfx settings to Ultra (I've done this only for testing purposes).
Apart from this, I've managed to finish the entire campaign on "Auto" gfx mode (textures autmoatically set to "Ultra") with only one crash.. but after reading several threads, I should rather say "I'm a really lucky guy!" anyway ;)
vineet2001
Enlisted: 2011-11-01
2011-11-01 05:38
Same problem here too... ATI 6770M 1Gb card
nowakl
PL Enlisted: 2011-10-25
2011-11-01 15:19
New drivers were released yesterday, but upgrade to v11.10 doesn't work (at least with ATI 6770M 2GB card).
YaRiN28
IL Enlisted: 2011-11-01
2011-11-01 22:43
wuckalooka said:
Get on task manager, if you have Teamviewer running, disable all teamviewer instances.

THANX !!!!!!!!!!!!!!!!!!! work for me
i'd disable the teamviewer and now i can play on full screen
soboth
PL Enlisted: 2011-11-05
2011-11-25 21:37
OK, here is my solution for HP Pavilion DV-7 with Intel HD & 6770M dual chipset:
1) install new HP graphics card drivers - 8.882.2.3000
2) install bios upgrade - version F.1B
3) in BIOS setup set switchable graphics from DYNAMIC to FIXED
4) run Win7, in CCC manualy set chipset to high performance
5) run BF3 and have fun with running full screen mode :)
PajtasBator
Enlisted: 2012-01-07
2012-01-07 17:59
Yup, TeamViewer tricked is what did it for me too.
LOSDUDE
Enlisted: 2011-11-14
2013-05-09 14:46
If you have BING desktop installed, it will interfere with full screen I've discovered. Hope this helps