Users on 32-bit operating systems have reported problems with installing the Battlelog web plugin and using Google Chrome. We're working to have this issue resolved before the end of the week. Affected users are encouraged to temporarily use another web browser.

Green texture. Help!!!

-Lg-Buff_Hamster
AU Enlisted: 2011-11-12
2012-06-10 08:04 , edited 2012-06-10 08:06 by -Lg-Buff_Hamster
I have a new pc now and all of a sudden i get this green texture problem and trees popping up where they shouldn't be.

Tried 2 drivers for at both 12.4 and 12.6 and both had the same problem. My old pc which had 12.4 on it didn't have this problem.

I'm thinking it's file corruption but i not 100% sure on that.

Anyone know what is causing this problem and know how to fix it?

http://img716.imageshack.us/img716/2263/bf32012061017530984.png [imageshack.us]
ManiacZapz
Enlisted: 2011-10-28
2012-06-10 08:12
have you tried disabling your hacks?

jokes.


specs of your PC?
Celican
GB Enlisted: 2011-10-28
2012-06-10 08:14
run repair.. from origin
Freedom is not worth having if it does not include the freedom to make mistakes. Mahatma Gandhi
Catamaranan
AU Enlisted: 2011-10-26
2012-06-10 08:28
Looks like your BF3 is corrupt. Do what AlunBah said, repair through Origin
CombatWombatAUS
AU Enlisted: 2011-11-14
2012-06-10 08:42
Your not running the new GTX are you?
-Lg-Buff_Hamster
AU Enlisted: 2011-11-12
2012-06-10 08:57 , edited 2012-06-10 23:37 by -Lg-Buff_Hamster
Nah i'm currently on the 6970.

OK i have updated the game through repair and it STILL has this problem.

I'll most likely have to reinstall BF3

EDIT - I have uninstalled BF3 and reinstalled with all updates and it still has this problem. OMFG HELP ME!!!!!
Dazzar1
AU Enlisted: 2011-10-28
2012-06-11 01:09
Sounds like typical ATI driver issues to me. Do you have a spare video card (especially a Nvidia based card) that you could use or borrow from someone just to see if it is driver/video card related (corrupted or buggy) or the BF3 install itself?
IvanTehFennec
US Enlisted: 2011-10-30
2012-06-11 02:15
When I had those problems, it was my video card that was artifacting. Had to get a new one.
-Lg-Buff_Hamster
AU Enlisted: 2011-11-12
2012-06-11 02:18
It's not the driver as i have a 6850 with the same driver and it had no problems.

It's not the GPU because it's only happening in BF3 and no other game i'm playing.
IvanTehFennec
US Enlisted: 2011-10-30
2012-06-11 02:21
I seem to remember having the problem before as well....I think I just re-installed the game and it fixed, also, updating drivers.
MacGruber77
BE Enlisted: 2011-10-24
2012-06-11 02:23
i get that sometimes with my gtx460sli after very long plays , green textureareas and shimmering artifacts on walls seen tru scope

but it always goes away if i start a new game
http://www2.goyk.com/aw333sas0903/scary/jessica_alba_scary.swf
-Lg-Buff_Hamster
AU Enlisted: 2011-11-12
2012-06-11 03:14 , edited 2012-06-11 03:15 by -Lg-Buff_Hamster
So far this is what i did in order

- Repaired BF3 through origin and that didn't work.
- Uninstalled BF3 and did a fresh install with all updates and that didn't work
- Uninstalled ATI driver and reinstalled and that didn't work (12.4 and 12.6)
- Swapped my 6970 with a 6850 and that also didn't work

WTF IS IT THEN????
EMPR-X
AU Enlisted: 2011-10-25
2012-06-11 03:43
Could it be heating problems?
-Lg-Buff_Hamster
AU Enlisted: 2011-11-12
2012-06-11 06:55
No it's not heating.

SOLVED.

Turns out that it was a lucid related problem. Since i'm using Lucid i had to go over everything again and noticed that in the bios it wasn't set as the primary gpu. Tested the game and runs perfectly.
Celican
GB Enlisted: 2011-10-28
2012-06-11 07:16 , edited 2012-06-11 07:16 by Celican
Glad you got it solved....
Freedom is not worth having if it does not include the freedom to make mistakes. Mahatma Gandhi
JustRefleX
AT Enlisted: 2011-10-27
2012-08-28 16:12
Could you terll me how ill set the Virtu MVP as a primary GPU? ive got the same issue in BF3
ACE_Lexus
GB Enlisted: 2011-10-28
2013-02-24 12:56
Thank you for creating this thread...

Just built a new PC and some of the terrain textures were in a neon green colour, as you can see from the following screenshot.

http://img834.imageshack.us/img834/701/screenshotwin320003l.png [img834.imageshack.us]

This thread, with the help of another, helped me quickly identify that Lucid MVP is a piece of junk software that I foolishly allowed to be installed in the first place.
PaPa_C_Lo
Enlisted: 2011-12-06
2013-02-27 09:29
++++ATTENTION++++

IT IS MOST LIKELY JUST THE WINDOWS UPDATE BELOW!!!

Platform Update for Windows 7 x64-Edition (KB2670838)

Download size: 11.2 MB

JUST GO INTO:
+ CONTROL PANEL
+ UNINSTALL A PROGRAM
+ VIEW INSTALLED UPDATES

FIND THE UPDATE LISTED ABOVE AND RIGHT-CLICK, REMOVE. YOU WILL HAVE TO RESTART AND WHEN YOUR COMPUTER RESTARTS WINDOWS UPDATE WILL WANT YOU TO RE-INSTALL THAT UPDATE AGAIN. YOU CAN THEN CHOOSE TO GO INTO WINDOWS UPDATE AND HIDE THIS UPDATE IF YOU FIND IT BOTHERSOME. I DO. THATS ALL YOU SHOULD HAVE TO DO TO HAVE NORMAL COLORED ROADS AGAIN!!!
C~£O
czemu
PL Enlisted: 2011-10-25
2013-03-02 13:08
PaPa_C_Lo said:
++++ATTENTION++++

IT IS MOST LIKELY JUST THE WINDOWS UPDATE BELOW!!!

Platform Update for Windows 7 x64-Edition (KB2670838)

Download size: 11.2 MB

JUST GO INTO:
+ CONTROL PANEL
+ UNINSTALL A PROGRAM
+ VIEW INSTALLED UPDATES

FIND THE UPDATE LISTED ABOVE AND RIGHT-CLICK, REMOVE. YOU WILL HAVE TO RESTART AND WHEN YOUR COMPUTER RESTARTS WINDOWS UPDATE WILL WANT YOU TO RE-INSTALL THAT UPDATE AGAIN. YOU CAN THEN CHOOSE TO GO INTO WINDOWS UPDATE AND HIDE THIS UPDATE IF YOU FIND IT BOTHERSOME. I DO. THATS ALL YOU SHOULD HAVE TO DO TO HAVE NORMAL COLORED ROADS AGAIN!!!
C~£O


It works, thanks.
Axxcel
DE Enlisted: 2011-10-27
2013-03-02 14:14 , edited 2013-03-02 14:26 by Axxcel
Had the same issue with green textures on roads and followed the advice from PaPa_C-Lo above:
Un-installing the windows update (KB2670838) solved the problem! This was great help! Kudos to PaPa_C_Lo! Much appreciated.
Initially i thought of heating problems with my graphics card but now I am so relieved I don´t have to discard my beloved Zotac GTX580 AMP!