Battlelog Plugin

SodaPhish
US Enlisted: 2012-12-29
2013-03-07 02:54
Okay, so I see there's a new update (blue box in the upper-right), but no matter what browser I use (IE 9, IE 10, Firefox 19, and Chrome can die in a fire), I have a number of issues:
1) the mouse-overs on the battlelog menus don't work. I.e. if I mouse-over multi-player, it used to pull up a sub-menu. Now, it doesn't, but that's not the big issue... the big issue is:
2) I can't install the new battlelog plugin. like I click on the blue box, and it does absolutely NOTHING.

SO, my question is this: where can I manually download the new battlelog plugin?

Thanks,
Corey
Topperbf2
US Enlisted: 2011-10-25
2013-03-07 11:53
This has been an ongoing issue,for quite some time now..I have tried firefox,same with IE,and still,it wont work.Tried the workarounds to no avail,would sure love to know what is causing this..

To answer your question,I know of no place to manually download the plug in..
Strict666
SE Enlisted: 2011-10-28
2013-03-07 14:28
Try and join a server and it should tell you to open Game manager that makes the blue arrow drop down to let you install.

I have another problem with it tho, I've installed the damn thing 8 times now but it still tells me to install it =(
I laugh in the face of danger, then I hide until it goes away.
MrHoltik
SE Enlisted: 2011-10-28
2013-03-07 14:33 , edited 2013-03-07 15:57 by MrHoltik
It seems the browser isn't holding the web plugin, for whatever reason.

Completely uninstall Battlelog plugin by using the Control Panel - Programs; Features/Add Remove Programs. Once uninstalled, clear your browser cache, cookies and temp files. Now you're need to reinstall in a clean state. Find the browser plugin (most likely in your Downloads folder) and run the program. It will install the plugin and you should be set!
SodaPhish
US Enlisted: 2012-12-29
2013-03-08 00:22
I"ve tried uninstalling the plugin, and now I can't even get the freaking plugin, because when I try and join a server and it asks me to download the plugin, it won't download it when I click on the download game manager link.

This is turbo-retarded.
BBQ_TIME_IN_HELL
NO Enlisted: 2011-10-25
2013-03-08 14:34
Okay, I just had the very same problem and I fixed it. It seems like Chrome didn't want to run anything on the battlelog site because it was deemed "unsafe" (won't open as https). So I right clicked the tab and chose to load content despite being "unsafe". Now everything works again, only not in https mode.
SodaPhish
US Enlisted: 2012-12-29
2013-03-08 23:51
I've tried adding battlefield.com as a trusted site, that hasn't helped. I'm still unable to play. fracking plugin says its installed.

HEY EA: I know you're worried about your sim city shit-storm, but could you PLEASE help the users who are able to play your OTHER games?
Jackson_338A
ZA Enlisted: 2012-08-05
2013-03-09 12:38
could this (problems with latest BL patch) have anything to do with me constantly getting disconnected from servers - regardless of ping or country?
tomvtv
BE Enlisted: 2012-08-09
2013-03-09 12:44
Latest battlelog plugin
=> http://www.mediafire.com/?kfcf5hogoftfdbe [mediafire.com]
Jackson_338A
ZA Enlisted: 2012-08-05
2013-03-09 15:34
ok thanks. I uninstalled the update, and installed the one t-tomvtv posted. (Thanks!).I then managed to get through a game without it crashing. Thanks.
Jagged17
Enlisted: 2012-01-08
2013-03-09 15:42
Exact same issue here (including the failing drop-down menus). From my thread at http://battlelog.battlefield.com/bf3/forum/threadview/2832654348462668677/ [battlelog.battlefield.com]

Battlelog doesn't recognize that I've installed the latest version of the browser plugin. Tried:

Uninstall/reinstall plugin
Ensure sonar plugins enabled in both browsers (FF/Chrome)
Updated Punkbuster
Uninstalled/reinstalled java

Happened since the game patched most recently.

Edit: Default browser has been both FF and Chrome, neither solve the issue.
Edit: Yes, I restarted my machine. and everything that needs to be run was done so as an administrator.
Theylok
AT Enlisted: 2011-11-03
2013-03-10 14:34
Same here. Drop down menus won't work and battlelog doesn't recognize the browser plugin. Even if it is not installed battlelog does not tell me to update or anything.
Right now nothing works.
Jagged17
Enlisted: 2012-01-08
2013-03-10 22:18
Link to latest plugin:

http://battlelog.battlefield.com/public/download/battlelog-web-plugins_2.1.3_108.exe [battlelog.battlefield.com]
Theylok
AT Enlisted: 2011-11-03
2013-03-11 12:11
I have the latest version already installed.
I've tested it on my laptop with Windows 7 + Firefox/IE (doesn't work) and Linux + Firefox (works) and on my iPhone 4 + Safari (works)
So obviosly it has something to do with the OS and the browsers I use.
A4V_Atomic
US Enlisted: 2012-03-17
2013-03-12 23:40
I can use the drop down menu, however as soon as I run the .exe to install the plugin the progress bar goes normally till like the last 9/10ths of it and then it like force closes....
TEAMSQUADGUY
CA Enlisted: 2011-10-25
2013-03-13 03:18 , edited 2013-03-13 03:21 by TEAMSQUADGUY
Has anyone got a fix for this? I seem to be able to install the plugin but it doesn't fix it at all. none of the menus work and it still says to download the latest plugin.
Tyriael75
DE Enlisted: 2011-10-26
2013-03-16 02:08
Same problem here :-(
rm-rFodderNZ
NZ Enlisted: 2011-11-06
2013-03-25 07:00
exact same problem here - sucks big balls
KenethHope
GB Enlisted: 2012-07-04
2013-04-05 17:10
unistall plugin and download manually http://answers.ea.com/t5/Battlefield-3/Battlelog-Plugin-Update/td-p/2430 [answers.ea.com]
WE ARE THE KNIGHTZ's WHO GO NEE! Trololo
1stWarlord
RO Enlisted: 2011-12-27
2013-06-16 06:04
Meh ,i kinda have the same problem here .. after the very last update shit got messed up here. I downloaded the web plugin ,which works only on INTERNET EXPLORER for me ( bullshit browser ,not going to use it .) while on my main browser ( Opera ) it says that i don't have it installed. This update even screwed my mouse sensitivity -.-