Battlefield 3 Crashing

egothrasher
Enlisted: 2011-10-24
2011-10-25 03:49
I have installed the new catalyst drivers, windows updates, and have even reinstalled origin and the damn game. Even after doing all this, the damn game keeps crashing, even the campaign.

Why release a game if its bugged to hell. Heck, not even a few hours after release EA was doing server maintenance. This game so far is no better than the beta and seems rushed and ill prepared for a release.

If anyone has solutions/ tips that would be much appreciated.
Soranoo
US Enlisted: 2011-10-24
2011-10-25 03:55
What is ur VGA?
egothrasher
Enlisted: 2011-10-24
2011-10-25 04:04
I am currently running HD5850 in crossfire. I can boot up Bad Company 2 (60 fps) and be playing in less than a minute. BF3, is another matter entirely, can't get the damn thing working. Finally managed to join an empty server, but anytime I try joining one with people, crash.
Bocados
US Enlisted: 2011-10-24
2011-10-25 05:08
HD6870 here. Crashing after about 10 minutes in any multiplayer game. Not overheating.
Sparkalot911
US Enlisted: 2011-10-25
2011-10-25 05:10
My game won't even freaking open, it gets to 126K on my processes ad then just dies. Im using an Asus G73JH running 64 Windows 7 and using an ATI Mobility Radeon HD 5870 Graphics card. I cant figure out what the problem is D:<
Aegis-77A
US Enlisted: 2011-10-25
2011-10-25 05:26
I'm running a single ATI HD6970 and am crashing consistently every 3-4 minutes. I've disabled overclocked, tried fullscreen and windowed mode, changed video settings but nothing seems to prevent the crashes.
ResinGlazedDonut
US Enlisted: 2011-10-25
2011-10-25 05:31
Same-ish problems, runs good for 10 minutes max if I'm lucky, than takes a dump. Updating to the new nvidia drivers only delayed the crashing.
DaReefer
Enlisted: 2011-10-25
2011-10-25 05:32
i am crashing to after about 5 min. latest nvidia drivers, gtx 480 wtf??
Frgr91
NO Enlisted: 2011-10-24
2011-10-25 05:37 , edited 2011-10-25 05:37 by Frgr91
I am crashing / Getting kicked by administrator in about 1min ingame in MP. SP works for some time, maybe 10-15min before it fucks up. I have a HD6990 Windows 64bit
Y-it-Earp
GB Enlisted: 2011-10-24
2011-10-25 05:37
yeah got the same shit going on here. GTX 570 i7 3.4ghz 16gb ddr 1600mhz


why release such a crock of shit.
SgtAstute
AU Enlisted: 2011-10-24
2011-10-25 05:39 , edited 2011-10-25 06:17 by SgtAstute
GTX 485M i7 2720 here. Crashing too, even on Single Player. No overheating though.

Running Windows 7 64 bit with latest Nvidia drivers (released 24th October).
5p0oky
US Enlisted: 2011-10-25
2011-10-25 05:43
Gtx 570 crashing here. SP and MP.
sometimes when i hit Esc it switches to windowed mode and still doesnt bring up the menu. WTF.
NevaGonnaGiveuUp
Enlisted: 2011-10-25
2011-10-25 05:44 , edited 2011-10-25 08:43 by NevaGonnaGiveuUp
Me too. Gtx 570, vista 32-bit, i5 750, 4gb ram.

Single player seemed fine at least for the amt of time I played, which was into the 2nd mission.

*edit* single player lasts 5-10 min before freezing.

Multiplayer is a different story. I can't manage to get 1 minute into the game before black screen, CTD or freeze. Problem occurs w/ beta drivers and latest nvidia drivers.

*edit* depending on map, i can play 1-5 min before freeze (metro always freezes within a minute).
DudeDeadly
CA Enlisted: 2011-10-25
2011-10-25 05:48
apdesign said:
Gtx 570 crashing here. SP and MP.
sometimes when i hit Esc it switches to windowed mode and still doesnt bring up the menu. WTF.
Exact same thing apdesing. Got a gtx570 with i7 2.8ghz 2600s
Cannibal1985
RU Enlisted: 2011-10-24
2011-10-25 05:53
HD5870 crash 10 min , fuck freeze ,Multiplayer "Game could not login to EA Online backend"
BOOMIJUSTSHOTY0U
Enlisted: 2011-10-25
2011-10-25 05:54
yup me too. Im running 3way gtx570 and nvidia surround. The game continually loops the intro scene on SP and once I'm in a MP game I get a message at around 5 mins saying I have been kicked by an administrator and in the lower left hand game status is says game error. I'm running latest drivers, sb @5 and 16gb ramso it isn't the setup. I had none of these issues in beta....wtf
MaTiZaN0zZ
TH Enlisted: 2011-10-24
2011-10-25 05:54
My com X4 945 3.5GHz ram 4GB HD5850 is same you .

it game crash in multipalyer only But in singleplayer and Co-op not problem .
xMartinxHx
GB Enlisted: 2011-10-24
2011-10-25 05:56
Yeah just had my first freeze (crash) on single player been playing a good few hours it was the mission with the jets just as i went to infra-red.

Played a good few hours of MP also early on and did not have one crash so far online, It was not like the hard crash that i got with the beta where i had to hard reset my pc but i had to random click the mouse button all over the screen to get back to desktop.

Win 7 64bit
i7 950
12 GB ram
460 GTX 1 GB in SLI 285.62
RusstiK18
CA Enlisted: 2011-10-24
2011-10-25 06:00
XFX Radeon 5850, Win 7 64bit, 4gb ram, i5 3.1ghz


Mine freezes in game and I have to do a hard reboot to unfreeze my PC. Anybody else having this issue?
FuT-Fourzero
Enlisted: 2011-10-24
2011-10-25 06:01
My entire pc got locked up like 5 times already... sometimes the game crashes, sometimes it crashes my entire PC.. go figure. Never had such problems with BF3 BETA and other games work just fine.

i7 980x @ 4.2
2x 580 3GB