BF3 has stopped working - WIN 7 32bit fix.

-D2K-hyrola
Enlisted: 2011-10-26
2011-12-15 13:14 , edited 2011-12-15 13:19 by -D2K-hyrola
Hi everyone.

This info was posted on another thread which was locked a while back and i only just came to find it this afternoon. Basically since release day and even worse with the latest couple of patches, if i ran my graphics at anything higher than medium my game would crash within 2-5 minutes without question. Game would lock up randomly then i would have to alt-ctl-del out to the desktop and find the "bf3.exe has stopped working".

Im not saying it will work for everyone BUT i can replicate the issue now and this definitely fixed mine. I must also note that the other thread i found had 32 pages and just about everyone claimed it fixed their game too. Unfortunately a moderator locked the thread because the title was all CAPS. Very annoying when it would have saved myself a lot of messing about and rage over the past weeks. Instead of locking it, they should have made it a sticky.

Anyways like the title says, this is only for Windows 32 bit systems. I am running win 7 32bit but this will work for vista as well as there is instructions for xp 32bit (who still runs xp these days:P)

Just to add, if i remove this command ie. revert back, with my BF3 graphics on high i crash 2-5 minutes in like i used to. When i re-add the command line again, the game is perfect again. I just finished a 2 hour session without 1 crash!

Ok the below looks like a lot to read, but really the fix only takes 10 seconds to do and then just reboot your computer :) It's just typing one command line into the command prompt and hitting enter. Simple as that!

*******************32BIT ONLY - USERS***********************

I've been having the crash problem - games in MP crashing in ~5mins, and SP crashing every so often. Found the solution from another game actually where I was having a similar problem - Empire: Total War.

BE AWARE, THIS IS ONLY A WORKAROUND - THE ISSUE STILL NEEDS TO BE FIXED. THIS IS A FIX FOR THOSE RUNNING 32BIT WINDOWS 7 AND WINDOWS VISA WITH 4GB RAM OR MORE.

From here on, I'm copy-pasting the instructions. This works for both Vista and W7. Got me through 20mins of MP for the first time though - longest game I've had. Haven't tested for longer.


What does it do?
It has to do two things that both rely on each other to work. For 32 bit operating systems we have to tell the operating system it can use more than 2GB user address space, 2.5GB actually, while leaving 1.5Gb for the kernel. We also have to set the Empire.exe executable to be allowed to address beyond the 2GB ceiling. 64 bit OS users don't have to do anything.

What does it help with?
This is not the solution for all crashes. It deals primarily with the crash to desktop that is caused by lack of virtual address space.Due to the unique nature of how addresses are mapped differently on each machine this crash may happen at different places and times of the game, even loading a map, menu or waiting on an AI turn. If you try this fix, and you follow directions properly, and it doesn't help you then your crash is due to something else.

How do I do it?
Follow directions explicitly. I have seen people consistently skip steps or not read the directions properly so it doesn't work for them whne they don't do what it says. it's not as complicated as it sounds, I'm just being thorough.

APPLY THE WORKAROUND (juicy caramel center)

Requirements

Only real requirements is that you have atleast 2GB RAM. You don't need beyond that even though we are allowing addressing up to 2.5 GB. Also following instructions and being somewhat familiar with working with files in windows is required. Make sure you are using Vista SP1. If not then you need this hotfix that fixes a major blunder with Vista address space - http://support.microsoft.com/kb/940105 [support.microsoft.com]
That's all, follow the 3 steps.

1) Prepare the operating system to be able to use beyone 2GB address space with a userva of 2.5GB (only 32 bit OS's need to do this): I am purposely using only 2500 for userva for specific reasons and any more will likely not be needed, as a result the kernel will have plenty of space to play in.

All 64 bit OS's
Nothing to do on the OS. Proceed to step 2 on setting the executable. 64 bit OS's running 32 bit binaries are also limited to 2GB application space.

XP 32
* Find your Boot.ini located usually on the C:.
If you cannot see it, you probably have system files hidden, then follow these instructions at microsoft (also uncheck "hide protected operating system files")
* Right click on the boot.ini and choose properties. Uncheck "read only"
* Open the boot.ini by double clicking it.
* Under the section called find the line that says "multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=" Wind ows XP Professional...". Yours may look a bit different. We are going to make a duplicate, so that if you make a mistake you will not harm yourself from booting into your computer. Drag you're mouse across the entire line, right click and choose copy. Then right below the line you just copied right click your mouse and choose paste. You should now have two lines one after another that are exact duplicates.
* Change the bottom line that you just copied with the following addition on the end. Add a space at the end of the line and then this without the quotes "/3GB /USERVA=2500"
* In that lower boot entry you just made, find the name of the operating system in quotes and change it to something like "Windows XP 3GB", so you can differentiate at boot up.
* Close and save the boot.ini.
* Right click on the boot.ini, hit properties, check read only.

Windows 7/Windows Vista
* In Windows 7/Vista go to Start menu. Go to Accessories. Locate the command prompt shortcut and hover mouse over it. Right Click on the shortcut then select Run as Administrator.
* In the command prompt type this exactly: bcdedit /set increaseuserva 2500. Then hit enter.
* Make sure you get a message back confirming the change was made. To verify the entry is there you can type just bcdedit, hit enter, and you should see the entry now listed.
* Then close the command prompt. You just told Vista to increase user virtual address (userva) space to 2500MB.
* Changes take effect on reboot but don't reboot yet.

SUMMARY
We extended the user virtual address space in XP, Vista and 7 to 2500MB, so now applications can utilize up to that much if they are set to be Large Address Aware. While some 32 bit games/applications are set, Empire is not.

2) Now reboot the PC because Windows needs to set the userva at 2500 which only happens after startup.

If you skip any step it will not work. When you have rebooted you should be good to go. Run the game as normal with the original game shortcut.

TO UNDO THE CHANGES
For the XP 32 bit just delete the line from your boot.ini.
For Vista 32 Open command prompt as administrator and type: bcdedit /deletevalue increaseuserva. That deletes the entry.
Reboot and you are back to normal.
HydraForce
AU Enlisted: 2011-10-28
2011-12-15 13:20
Is this the same as going to msconfig > boot >advanced options > maximum memory?
-D2K-hyrola
Enlisted: 2011-10-26
2011-12-15 14:22 , edited 2011-12-15 14:30 by -D2K-hyrola
Negative. I believe that is purely for launching windows only.

My above post sets the virtual address space available for applications to 2500MB. By default it is 2000MB.

Trust me, just give it a go. You have nothing to lose. If it doesn't fix/greatly improve your bf3 crashing problems then its just as easy to remove it from your boot loader by running the command at the end of my post.

I just played another hour or more and still not one crash and all settings are now ultra! All accept i have motion blur off and ambient occlusion off. Prior to tonight, ULTRA settings my game would crash within minutes of entering game.
gibble92
DE Enlisted: 2011-11-03
2011-12-15 15:21
yeah, this really helped
printer_cro
HR Enlisted: 2011-12-10
2011-12-15 16:04
i have 2gigs of ram, will this work?
-D2K-hyrola
Enlisted: 2011-10-26
2011-12-16 00:55
Yes it will work with 2gb or more ram. Give it a go printer_cro ;) It can't hurt and easy to revert!

Again today... game is perfect for me still. No crashing and smooth as silk. I can't believe i didn't find this ages ago... would have saved me so much time and frustration.

I have no idea why DICE hasn't fixed the game knowing this information :/
printer_cro
HR Enlisted: 2011-12-10
2011-12-16 22:55
thanks, man i love you :D
django1364
TT Enlisted: 2011-10-31
2011-12-17 17:42
HEY OMG-hyrola I am running OS win7 64
I did exactly what you said, and it work for me, i also set my video card to auto, lower the motion blur. everything for awhile, until my motherboard fried haahah serious. i went to RMA it, brought a new one and everything working normal, thanks again
fiatlux7
Enlisted: 2011-10-26
2011-12-17 18:06
i have windows 7 ultimate x64 and it didnt worked for me. I always get the bf3.exe crash when i try to run it.
MorsLetum
Enlisted: 2011-10-25
2011-12-18 23:20
this work for me now i can play :)
-D2K-hyrola
Enlisted: 2011-10-26
2011-12-19 07:29
This has now solved the problem for friends of mine after i got them to do it as well over the weekend. I would say this will fix the problem for 9 out of 10 win32 bit users.

It just sucks that the community are finding workarounds/fixes for DICE. Why should we be the ones wasting all of our time troubleshooting their game?

fiatlux7 - Did you run the command as administrator? It wont work unless you run the command prompt as administrator. If you did do that then sorry it didn't solve your issue as i can't help you with a 64bit os. It will be something else causing your bf3.exe to stop working.
ChewyTurd
US Enlisted: 2011-12-11
2011-12-23 07:25
Running win7x64. I did the steps, and im still crashing. It freezes then I have to bring up the task manager to kill bf3s process. Disabling CF, and as well removing the 2nd vid card still doesn't help. This is BC2 all over again. Same problems.
Gmaziero
BR Enlisted: 2011-12-17
2011-12-24 18:27
not work yet ...
Ghaol
IE Enlisted: 2011-10-30
2011-12-24 19:14
Got my very first conquest large game done today because of this! Fair fecking play to ya man! DICE and their excuses have almost driven this Irishman to drink! You've saved me a fortune!!! :)
ReSonar
MY Enlisted: 2011-10-26
2012-03-14 15:39
im using 64bit win7 so sad...
Seyfert_Stryker
PT Enlisted: 2011-12-04
2012-06-13 15:49
http://www.youtube.com/watch?v=vN8e2PNHPEE&feature=related [youtube.com]
Or just do that.
ooKALLEoo
DK Enlisted: 2011-10-27
2012-06-13 16:04
The fix is ​​only to 3GB RAM


Here is the real fix
http://forum.battlelog.org/viewtopic.php?f=22&t=13 [forum.battlelog.org]
SL4Y3R_srb
RS Enlisted: 2012-07-28
2013-01-19 19:48
Onboard REALTEK Sound is causing the preblem..


****TRY THIS****

Right click on the audio icon in your tool bar and choose playback devices. Highlight speakers and click on properties. Click on the advanced tab and untick "Allow applications to take inclusive control of this device" Then apply.

YOU'RE WELCOME
BiffDangles
US Enlisted: 2012-01-02
2013-01-27 15:22
This be bullshit I say.

Windows 7 64bit. This shit started happening a couple weeks ago and is getting progressively worse. Either I get "Game Disconnected: Something went wrong" or BF3 has stopped working.


They might as well just put up a message that says, "Glad you Paid, no go blow yourself"