The security certificate has just expired.

Enlisted: 2011-11-17
2012-06-08 12:16
This Connection is Untrusted

You have asked Firefox to connect
securely to, but we can't confirm that your connection is secure.
Normally, when you try to connect securely,
sites will present trusted identification to prove that you are
going to the right place. However, this site's identity can't be verified.

What Should I Do?

If you usually connect to
this site without problems, this error could mean that someone is
trying to impersonate the site, and you shouldn't continue.

Technical Details uses an invalid security certificate.

The certificate expired on 9/06/2012 9:29 AM. The current time is 9/06/2012 9:36 PM.

(Error code: sec_error_expired_certificate)

I Understand the Risks

If you understand what's going on, you
can tell Firefox to start trusting this site's identification.
Even if you trust the site, this error could mean that someone is
tampering with your connection.
Don't add an exception unless
you know there's a good reason why this site doesn't use trusted identification.
Enlisted: 2012-05-04
2012-06-08 21:08
I am having this problem as well. Please give us a reply ASAP
AU Enlisted: 2011-10-30
2012-06-08 22:37
i have same issues
AU Enlisted: 2011-10-27
2012-06-09 00:09
Hello EA. Looks like you need to update your trusted SSL certificate.
NL Enlisted: 2011-10-24
2012-06-09 00:10
What a fools at EA, I get the same message expired certificate.
US Enlisted: 2011-10-24
2012-06-09 00:11
Just got this error too ... Technology by ESN.. does it again. NOT.
US Enlisted: 2011-11-01
2012-06-09 00:11
Happening here now in Chrome and Firefox.
CA Enlisted: 2011-10-25
2012-06-09 00:15
just happened to me too, good job EA.. noobs
US Enlisted: 2011-11-01
2012-06-09 00:16
I'd tread carefully for the time being and try to avoid playing if you can until they can fix it.
Enlisted: 2011-11-01
2012-06-09 00:16
Yep me too bloody useless company if they can't even renew their certificate!!
US Enlisted: 2011-10-25
2012-06-09 00:17
same here.
Enlisted: 2011-11-03
2012-06-09 00:19
Enlisted: 2011-11-01
2012-06-09 00:20
I just tried going from here back into multiplayer and I do get the server list but it won't let me join anything, just great!!
CA Enlisted: 2011-10-27
2012-06-09 00:23
Same problem
US Enlisted: 2012-05-26
2012-06-09 00:24
Same thing here, worked fine day before yesterday now today I can't connect to any servers because of this certificate issue. WHAT DO WE DO???? HELLO EA???
Enlisted: 2011-10-25
2012-06-09 00:25
happened here IE9 even if i allow still cant game
Burn and Turn
US Enlisted: 2011-10-26
2012-06-09 00:25 , edited 2012-06-09 00:25 by xBL4D3R
ArchBeliaal said:
Same problem

Firefox 13.0
| CoolerMaster Trooper case | Intel i7 4790k | MSI Z97-3 | EVGA GTX 760 4GB | Corsair Vengeance 16GB @1866 | Corsair 240/120 GB Neutron SSD | Corsair CX750 PSU | Corsair H55 H2O Cooler | Asus 24" 3D 1080p 144hz | Win7/64 Pro | Custom settings (Medium/high) = 144 FPS locked. | UCAV Voices: |
GB Enlisted: 2011-10-25
2012-06-09 00:26
Me as well, oh well DayZ here i come!

Mickey mouse operation? really!
Enlisted: 2011-10-27
2012-06-09 00:30
Same here! This is totally and utterly ridiculous. What an epic FAIL again!
GB Enlisted: 2011-10-28
2012-06-09 00:31