DirectX Error

KingPrussia23
US Enlisted: 2011-10-25
2012-06-26 05:22
DirectX Function "GetDeviceRemovedReason" failed with DXGI_ERROR_DEVICE_REMOVED. Hardware device removed..GPU: "Nividia Geforce GTX 560", Driver: 30142. This error is usually caused by the graphics driver crashing; try installing the latest drivers. Also make sure you have a supported graphics card with at least 512 MB.

I reinstalled the latest drivers. Have DirectX 11. IDK?

This has never happened before.
Wilach
CZ Enlisted: 2011-11-10
2012-06-26 09:47
Same problem. Cant solve it.
SDKingFD
AU Enlisted: 2011-10-26
2012-06-26 13:24
I have this exact same problem.

I just downloaded the game two days ago and I have spent the last two nights trying to figure out what is is going on. I cannot even launch the game. I have uninstalled and reinstalled - the game, Nvidia drivers etc but with no luck. Pretty frustrating.

Here is my error https://lh6.googleusercontent.com/-SoealKobF8Y/T-mahcvLK5I/AAAAAAAABkw/S9OQNvq2H_s/s800/DirectX%2520Error.jpg [lh6.googleusercontent.com]
TomManowar1969
DE Enlisted: 2012-06-28
2012-06-28 14:37
Hi,

I own a "EVGA GTX 690 Signature Edition" since one week. I tried the recent driver, also the newest beta version. Installed/reinstalled DirectX, etc., but
still have the same problem, too. Game runs and after a while is crashed with error message:


DirectX function "GetDeviceRemovedReason" failed with DX1_ERROR_DEVICE_REMOVED: Hardware device removed. GPU:"NVIDIA GeForce GTX690", Driver 30142. This error is usually caused by the graphics driver crashing; try installing the latest drivers. Also make sure you have a supported graphics card with at least 512 MB.
SDKingFD
AU Enlisted: 2011-10-26
2012-06-28 14:57
I spent a bit of time online tonight with EA support with no luck yet in resolving the issue. They are going to be in contact in the next day or two to give it another go.
TomManowar1969
DE Enlisted: 2012-06-28
2012-06-28 17:35
I know it makes no sense to buy a 1000Euro GTX 690 but as a temporary workaroud I reduced the detais from "ultra" to "high" what fixed the problem for me until a final solution is available.
1Lister-of-Smeg
GB Enlisted: 2011-10-29
2012-06-28 17:37
What are your full specs?
Intel i5 2500K @ 4Ghz, Asus P8P67 Evo, 16GB Corsair Vengeance 1600Mhz, 120GB OCZ Vertex 3, Sapphire ATI Radeon R9 280X Toxic OC, 650W BeQuiet Gold, Thermaltake Armor, Win 7 64Bit HP, XL2411T 24" 144Hz Gaming Monitor
TomManowar1969
DE Enlisted: 2012-06-28
2012-06-29 09:57
OS: Windows 7 Ultimate x86 Service Pack 1
NVidia Driver: 304.48 Beta

Board: Intel DP43TF
CPU: Intel Core2Quad Q9550 2.83GHz
GPU: EVGA GTX 690 signature edition
Sound: Creative SB X-Fi
Memory: 4GB
Network: Intel 82567V
Monitor: Panasonic 42 inch plasma TH-42PZ85EA
Mouse: Razar Naga RZ01
Keyboard: Logitech C19

BF3 Settings:
Graphic Quality: High
Texture Quality: High
Shadow Quality: High
Effects Quality: High
Mesh Quality: High
Terrain Quality: High
Terrain decoration: High
Antialiasing defered: 4x MSAA
Antialiasing post: medium
Motion blur: off
Anisotropic filter: 4x
Ambient occlusion: SSAO
RazzerKFG
DK Enlisted: 2012-06-28
2012-07-03 09:37
Been having crashes myself lately, but no popup messages, but now I'm getting the excat same message. using a GTX 560 se on a brand new machine
vetalking84
Enlisted: 2012-07-08
2012-07-10 13:07
i have the same problem
DirectX function "GetDeviceRemovedReason" failed with DX1_ERROR_DEVICE_REMOVED: Hardware device removed. GPU:"NVIDIA GeForce GTX670", Driver 30142. This error is usually caused by the graphics driver crashing; try installing the latest drivers. Also make sure you have a supported graphics card with at least 512 MB.
penguin337
US Enlisted: 2012-06-30
2012-07-10 13:43 , edited 2012-07-10 14:27 by penguin337
Recently received the same exact error message.

My game crashes in exactly a minute or so. BUT it would seem that this is having an effect on other games. My frame rates have dropped to less than half with Shogun 2 and I just experienced a driver related crash with Company of Heroes which is an old and way less taxing game than BF3...

I have no idea whats going on.


Update: Usually my crashes are preceded by either a sharp drop in FPS, and then a complete lock up of my system with a really loud buzzing noise loop.

SOMETIMES if I am lucky the frame rate will dip first and I will be able to Ctrl Alt Del before the problem requires a hard boot but, its very random HOW it crashes. It just always does within a minute of joining a game.
Nuttydave
GB Enlisted: 2011-10-24
2012-07-10 14:41
are you all using nvdia?
Only premium people have premium. Now fetch me my weapon poor people.
penguin337
US Enlisted: 2012-06-30
2012-07-10 15:31
I am!

Gigabyte Windforce GTX670 OC here.
SDKingFD
AU Enlisted: 2011-10-26
2012-07-11 10:42 , edited 2012-07-11 10:43 by SDKingFD
Nuttydave said:
are you all using nvdia?


Yes Nvidia here, problem still occurring and still no fix.

EA support did not get back to me in 48 hours as they said they would. It has now been more than 2 weeks.
k4t4r4
GR Enlisted: 2011-12-16
2012-07-11 11:22
Nvidia problems ... got it too...
Mr_No-Printz
US Enlisted: 2011-10-26
2012-07-15 02:36
same here
Nuttydave
GB Enlisted: 2011-10-24
2012-07-15 03:06
Get nvidia forums and find out when they are gonna fix there drivers seems to be a lot of nvdia people with problems more since the last update
Only premium people have premium. Now fetch me my weapon poor people.
archlucifer666
Enlisted: 2012-04-18
2012-07-20 17:30
I found a fix for it. Go to device manager and roll back previous driver changes. The one I had was updated on 15/05/2012, rolled it back and battlefield is working now no problem. Hope this helps
HST-MuTTer
DE Enlisted: 2011-10-26
2012-07-20 18:15 , edited 2012-07-20 18:17 by HST-MuTTer
TomManowar1969 said:
OS: Windows 7 Ultimate x86 Service Pack 1
NVidia Driver: 304.48 Beta

Board: Intel DP43TF
CPU: Intel Core2Quad Q9550 2.83GHz
GPU: EVGA GTX 690 signature edition
Sound: Creative SB X-Fi
Memory: 4GB
Network: Intel 82567V
Monitor: Panasonic 42 inch plasma TH-42PZ85EA
Mouse: Razar Naga RZ01
Keyboard: Logitech C19

BF3 Settings:
Graphic Quality: High
Texture Quality: High
Shadow Quality: High
Effects Quality: High
Mesh Quality: High
Terrain Quality: High
Terrain decoration: High
Antialiasing defered: 4x MSAA
Antialiasing post: medium
Motion blur: off
Anisotropic filter: 4x
Ambient occlusion: SSAO


Board: Intel DP43TF
CPU: Intel Core2Quad Q9550 2.83GHz
GPU: EVGA GTX 690 signature edition???????????????
Maybe u should get a system that can handle ur graphics monster sooo lol
Für BF3 musste dann doch mal ein Rechnerupdate her:) Cpu: INTEL i7-2600K @4x4,40GHz Gpu: nVidia GF GTX 680 mit 2048MB GDDR5 RAM Ram: 16GB DDR3 PC1600 RAM G.Skill MB: Gigabyte GA-Z77X-UD3H Mainboard Sockel 1155 Keyboard:Razer BlackWidow Sound: Usb Logitech G930 Headset/SB X-FI Mouse:Razer taipan
BOOM_Creeper
US Enlisted: 2011-10-25
2012-07-20 18:53 , edited 2012-07-20 19:18 by BOOM_Creeper
Same problem I thought I fixed it yesterday. but it was just a fluke. Im getting fed up with this game. Havent had much time to play at all due to all the crashing. I've got a $3000 Rig. I7920, 12 gigs of ram, 2gtx 275's
old yes. why it cost so much :(

I think its actually EVGA PRESICION that is causing my problems. my card software died and my temps went over 100.. yikes