Thread is locked.

DirectX Error

AdmiralGUNN
EG Enlisted: 2012-11-21
2012-11-30 20:03
i have the exact same prob using nvidia driver and idk how to fix it ...cant even uninstall the driver
FIDELI7Y
SE Enlisted: 2011-10-28
2012-11-30 20:27
Hello KingPrussia23!
What you could do, is to download an earlier graphics driver if you still face the same issue while using the old drivers! That can help, and if it wouldn't help. i'd recommend you to download another version of DirectX.
DICΞ Friend/Approved since May 31, 2013
AdmiralGUNN
EG Enlisted: 2012-11-21
2012-11-30 21:05
EXP3RT_SWE said:
Hello KingPrussia23!
What you could do, is to download an earlier graphics driver if you still face the same issue while using the old drivers! That can help, and if it wouldn't help. i'd recommend you to download another version of DirectX.

that does not help...or atleast it didnt help me i even have the prob of the nvidia drivers not reading my installed 1
Xnicnicx
Enlisted: 2011-10-27
2012-12-23 04:50
I'm on Windows 7 so I just changed the compatibility to Windows XP (Service Pack 2) and it worked like a charm.
Megakuk
SE Enlisted: 2011-10-26
2013-01-10 16:52
I have the same problem with 2 HD7970. Tried all workarounds without luck :(
FRAGj0hnny
US Enlisted: 2011-11-03
2013-01-15 00:14 , edited 2013-01-15 00:16 by FRAGj0hnny
This forum consists of nothing but people saying I have the same problem. Does anyone have a solution?

I NEED SOLUTIONS!! :(
D4rkM4gic
ZA Enlisted: 2011-11-19
2013-01-18 14:26
Same problem. Only ever on the big maps.
DirtySepee
Enlisted: 2012-09-06
2013-03-13 21:07
fucking useless to repost i got some problem, got same problem and same problem. not interested we need some fucking answers not 10 pages useless text where the solution dissapears. BTW i got same problem :D
Jakubpl
SE Enlisted: 2013-02-25
2013-03-16 21:58
Hi everybody, after one day trying every possible fix, I found what was wrong on my computer!

Here is the situation: The game was working well when I first installed BF3 on my HP ELiteBook 8570w, with a Quadro K1000M ... until I updated a lot of softs and drivers from HP website.

So I tried to upgrade to other drivers, directx, reinstall the game, downclock my GPU...
Then I started uninstalling everything I installed since it was working, and I found this :

"SMSC Core Graphics Software"

Then I read this article: http://www.shouldiremoveit.com/SMSC-Core-Graphics-Software-29167-program.aspx [shouldiremoveit.com]

They say it can cause DirectX errors! I uninstalled it right away, and guess what?

It works perfectly now!!!! :D

Had to share this, I've lost too much time on this.
Hope it helps!
Solartwigs
Enlisted: 2012-02-12
2013-05-18 01:02 , edited 2013-05-18 01:03 by Solartwigs
Same problem i have found no fix. tried everything even a reinstall of my whole os/game... didnt fix squat...

Oh and your should i remove it said origin was top% of things to remove...LOL wtf junk program
captainjerk
AU Enlisted: 2011-10-25
2013-05-18 05:01
0-THUNDERCAT-0 said:
TomManowar1969 said:
OS: Windows 7 Ultimate x86 Service Pack 1
NVidia Driver: 304.48 Beta

Board: Intel DP43TF
CPU: Intel Core2Quad Q9550 2.83GHz
GPU: EVGA GTX 690 signature edition
Sound: Creative SB X-Fi
Memory: 4GB
Network: Intel 82567V
Monitor: Panasonic 42 inch plasma TH-42PZ85EA
Mouse: Razar Naga RZ01
Keyboard: Logitech C19

BF3 Settings:
Graphic Quality: High
Texture Quality: High
Shadow Quality: High
Effects Quality: High
Mesh Quality: High
Terrain Quality: High
Terrain decoration: High
Antialiasing defered: 4x MSAA
Antialiasing post: medium
Motion blur: off
Anisotropic filter: 4x
Ambient occlusion: SSAO
wow gpu with a cpu like that what a waste you got2 be takeing the piss and 4gb ram makes my day


I used to run my GTX580 with the Core2Quad Q9550 2.83GHz and it ran at about 60% max usage and the game ran like crap.

A 690 with that old CPU - lol.
LightFu
NL Enlisted: 2012-06-15
2013-06-08 22:16
i never had this problem in the past i have it since a couple of weeks and i got nvidia GeForce GTX 680.
its weird and i even can play it easily on ultra settings.
Pc Specs. Motherboard; MSI X99S SLI PLUS. PowerSupply; Cooler Master B500 watt ATX. Processor; i7-5820 3,3 GHz (3,6 GHz Turbo Boost). Cooler; Be Quiet! CPU Cooler Shadow Rock Slim, 160W. Memories; 8GB DDR4/2133 Crucial CL15 KIT Retail. Graphix Card; GALAX Nvidia GeForce GTX 980 4GB. SSD; 250GB SATA3 Samsung 840 EVO.
cheesywinky
GB Enlisted: 2011-10-28
2013-06-09 17:28
Similar problem here too!!

http://battlelog.battlefield.com/bf3/forum/threadview/2832654490286832306/ [battlelog.battlefield.com]
Hitme30
NL Enlisted: 2011-10-26
2013-06-19 20:30
Same problems here, since the latest update...
FishMadeOfCandy
Enlisted: 2012-02-12
2013-07-08 01:17
This sucks, I just got Premium, and I am not even beeing able to startup the f*cking game! Please, I need a solution for this!
Megakuk
SE Enlisted: 2011-10-26
2013-11-29 22:32 , edited 2013-11-29 22:32 by Megakuk
This same problem was frequently occurring on BF3 for alot of people. Dont have your hopes up for DICE to do anything about it.
Riggier
RU Enlisted: 2014-01-03
2015-08-15 19:55
Блять, вы американцы (или англичане, да хуй вас знает), вы такие нытики, написано "проблема, помогите" вас просят решить её, а не написать какие вы несчастные и есть ли у вас та же проблема. Короче, скажу как нормальный русский мужик, не нойте, если у вас такая же проблема, это не значит что нужно писать "ой, блять, у меня такая же проблема, я тоже такой несчастный, помогите." Я из за таких нытиков не могу найти здесь ответ.
 
Thread is locked.
Thread is locked.