Repair Install

Fatcraig
US Enlisted: 2011-10-25
2011-10-27 19:28
Is anyone else trying this only to get a 48.1MB download at the end of it every time you try to repair install?

It's beginning to make me think that there is a patch although it is just not applying those files correctly...


Side note:

Contacted EA Support about the game crashing at map change, they apparently have no information on it. They stated to make sure drivers are up to date, do repair install and reset winsock. None of which worked and upon contacting them again they said that no information about this was available and that they would forward this issue to where it needed to go... (wherever that is...)
Cr0nq
Enlisted: 2011-10-25
2011-10-28 00:31
I know it seems counter intuitive, but:

Repair Install = Break Install

Apparently EA just mispelled it and needs to correct it.
BOKEYNAN
CA Enlisted: 2011-10-25
2011-10-28 00:34
i did the repair install and my game seems to be running great for the past two days. but i dont even know if it affected anything
VaNiilaa
GB Enlisted: 2011-10-24
2011-10-28 00:39
Same happens to me. I assume when it repairs your install it repairs the files to an unpatched state, and then reloads the patch afterwards.
psykogundam
Enlisted: 2011-10-27
2011-10-28 20:11
I used repair install and i ran the download to 100%. there was no que for me to end the process and it didnt dissapear by itself so i pressed the X to close the window within origin. (when somethings at 100% for over 5 minutes it should be done right?)

Now it gives me "ready to install" but it doesnt initilise the install process. It tries but fails. now in my directory, i dont have an EXE.

I'de love to know what the hell is going on. I am furious.
mikey3k
US Enlisted: 2011-10-25
2011-10-28 20:21
psykogundam said:
I used repair install and i ran the download to 100%. there was no que for me to end the process and it didnt dissapear by itself so i pressed the X to close the window within origin. (when somethings at 100% for over 5 minutes it should be done right?)

Now it gives me "ready to install" but it doesnt initilise the install process. It tries but fails. now in my directory, i dont have an EXE.

I'de love to know what the hell is going on. I am furious.

It breaks your install, uninstall the game and reinstall from the discs. Just make sure to check NO when it asks if you want to delete your saved games. Repair install actually breaks the install for many people. I had the same problem you had.
Piefaceclown
US Enlisted: 2011-10-25
2011-10-28 20:22
When I tried repairing my install it no longer recognized the game as installed and I had to reinstall it entirely twice.
PC Master Race
bryanalanblack
Enlisted: 2011-10-27
2011-10-28 20:23
im getting a 2.2 GB updaate right now??
RiskySash
Enlisted: 2011-10-25
2011-10-30 20:19
The Issue:

I am having a problem launching the game. Everything is up to date, I tried launching from Firefox, Chrome, and IE as default browsers.

I launch Origin as admin then click the game to play from the library (which says is up to date), then it launches the browser and says Game: Battlefield 3 Update Available. When I click that, it brings me to the store to buy the game. I then have to click on My Games and launch it again, which opens a new browser window. The cycle just continues on and on, is there a solution to this? Who else is having this problem? I updated .Net to version 4 and updated Java since I heard that helps, but it doesn't work. I pre-ordered from Amazon and the game was installed into Origin Games/Battlefield 3. "

The fix:

You should try repairing first (by right clicking the game inside origin) which didn't work for me so...

Here is what I did to fix this problem:

*this fix requires re-downloading the game from origin.

Uninstall BF3 beta (if you have it)
Remove BF3 beta files from Origin Games folder.
Install Microsoft .net version 4.
Update Java.
Uninstall Origin.
Install Origin.
Uninstall BF3 plugin. (from control panel)
Uninstall BF3.
Start the download process again from origin.
It should now install correctly.

My previous installation was a pre-load from amazon which might have been the issue than current download.

Other stuff I did:

Additionally I did this to stop the game from crashing after the update issue was resolved.

I was getting black blank screen crashes between matches so I did the following:

1. Set my graphics card gtx 470 to default settings instead of overclocked speeds.

2. I was having sound problems. Downloaded latest g35 surround headset drivers from logitech. And custom add BF3 profile same as bf bc2.

3. Set Firefox as default browser to launch game. Chrome was causing issues.

So far so good.

Have you downloaded the latest Microsoft .net version 4 and updated your java? (Not sure if these help but some others were saying this).

Have you tried multiple browsers?

Update your sound drivers and try turning off HI-FI in audio settings to headphones and enhanced sound off.
Zoliax
HU Enlisted: 2011-10-27
2011-10-30 20:22
that 40+ MB is the BF3.exe file people i know every time i gett BF3.exe stopped working i do it and it works again the the .exe is 40-50 mb too lol
l33tje
BE Enlisted: 2011-10-31
2011-11-04 18:37
replayforum thx very much it helped for me

I couldn't start the game "Install the game first" => update avaible => origin store => didn't want to repair
Hotshield also didn't work..

Thx man
TRoPixX
Enlisted: 2011-10-29
2011-11-08 17:15
you just must install hotspot shield and then it works

sorry for my bad english
crckdns
DE Enlisted: 2011-10-26
2011-11-08 17:18 , edited 2011-11-08 17:18 by crckdns
the "repair install" thing (install-loop)... hit me 4 times in a row on the first day (25th of October) ..then I gave up and didn't try it ever again^^
Join our happy, fast spawn,high-ticket server! Search for " Fail0r "
mackintosh77
Enlisted: 2011-12-09
2011-12-11 04:32
Installed BF3 - then waited while the additiuonal 4gb downloaded and installed. Ran like a dog. Disabled unrelated programs on startup to free some memory, rebooted a few times and now it is telling me it neeeds to be installed. The repair wants to download 16gb. This is crap. EA
kehumff
Enlisted: 2011-10-28
2012-01-12 15:46
Leave a reply...
psykogundam said:
I used repair install and i ran the download to 100%. there was no que for me to end the process and it didnt dissapear by itself so i pressed the X to close the window within origin. (when somethings at 100% for over 5 minutes it should be done right?)

Now it gives me "ready to install" but it doesnt initilise the install process. It tries but fails. now in my directory, i dont have an EXE.

I'de love to know what the hell is going on. I am furious.


Did you ever resolve this as i am having this problem now and i have tried for 5 whole nights to get it back on.