Browser Plugin.

Mickeyjhart
NL Enlisted: 2011-10-28
2012-02-28 17:28
The message keeps coming up i have to install a browser plugin but everytime i install it, it pops up again when i open a new Battlelog.. What is up?
WALKINGCORPSE1
US Enlisted: 2011-10-25
2012-02-28 17:29
just try to reboot the comp.
http://www.youtube.com/user/po3walkingcorpse?feature=mhee
Chuck_Mawhinn3y
US Enlisted: 2011-10-24
2012-02-28 17:39
computers 101
after you install something
1 reboot computer
2 profit
wait forgot this was battle log
1 try starting
2 complain on forums when it doesnt work
3 profit?
=U= Rock BF4 Servers, just search =U=
HighlyModified
US Enlisted: 2011-10-28
2012-02-28 17:43
Chuck_Mawhinn3y said:
computers 101
after you install something
1 reboot computer
2 profit
wait forgot this was battle log
1 try starting
2 complain on forums when it doesnt work
3 profit?

I was reading your comment when "something went wrong"
CuztomCam
AU Enlisted: 2011-10-26
2012-03-11 01:06
restarting doesn't fukin work mmmmmmmmmmmmmmm
Browser plugin up to date .... Join voice .....
1: need to install browser plugin ... AGAIN WTF over and over again
2: Windows cannot find Ç:\program files (x86)\battlelog web plugins\soner\0.70.4\sonarHost.exe make sure you typed the name correctly and then try again
any one that can help please would be much appriciated
i had it working before and i don't think i changed any settings unless my younger brothers or son did cheers
power2player
Enlisted: 2012-04-06
2012-04-15 00:59
will it show up on your windows cause im not allowed to download anything
ID_Mungojerrie
AF Enlisted: 2012-06-16
2012-06-16 19:51
Why do I ever need this browser plugin? Is it so hard to implement fully functional lobby system inside the game? Why do I need Origin client then?
FAC-IN_Sneed
GB Enlisted: 2011-10-28
2012-06-16 20:05
uninstall and reinstall the browser plugin. I had exactly the same problem. The file it says is missin..IS missing. Just reinstall it will fix it
terrain77
US Enlisted: 2012-03-18
2012-08-12 04:39
i completely unistall the pluggins but it says again but where do i download it from?
Duhkilla
US Enlisted: 2011-10-25
2013-06-24 01:13
Doesn't work. I deleted, uninstalled, rebooted, and who knows what else. Origin must have changed something. I loaded, reloaded, deleted, and reloaded, rebooted, and reloaded, still the same damn problem! WTF
BlackFlag707
Enlisted: 2011-11-25
2013-06-24 01:19
You download it from the flashing little box in top right corner, same box with check mark on it where you look at stats for las MP game played. I selct run instead of download and it gets scanned by MSSE then installs, never an issue.
Duhkilla
US Enlisted: 2011-10-25
2013-07-20 23:49
I tried what it says above and it doesn't work either. Is there anyone on these forums that can offer any assistance other than saying reboot, or install from this or that? I have tried everything, and the darn plugin will not load.
RealLRP
US Enlisted: 2011-10-26
2013-10-30 00:52
I'm having the EXACT thing happen after installing Battlefield 4. I'm just trying to play campaign mode or single player and I keep getting that same message. I've uninstalled, rebooted etc., etc., and still the same crap. Never had any issue before this. I've been playing BF3 right up to the day I installed BF4 and no issues. Anyone know what's going on here? I'd appreciate being able to play BF4. Only been waiting a year or so for it to come out - This sucks anus!! HELP!!! PLEASE!!
spicata-
SE Enlisted: 2011-10-28
2013-10-31 13:25
Same here, browser plugin problem
Murf_7290
Enlisted: 2011-10-24
2013-10-31 14:17
Got it working with firefox. went into plugins, made sure ESN SONAR API was on Always Activate and ESN Launch Mozilla Plugin was on Aways Activate (mine was not) restarted firefox and voila, all set
MIRVValver
GB Enlisted: 2011-10-27
2013-10-31 14:42
Same issue here - trying to play BF3 - go to launch a game via Battlelog, prompted for the plugin upgrade. Doesn't matter if I run it, or save it then run that, I get stuck in the loop of it just asking over and over for the plugin to be downloaded and installed.

I cant even play single player! :(

(IE 11 on Win7 64bit BTW)
Limeyfraggedu
GB Enlisted: 2011-10-28
2013-10-31 15:12
DeathsDesign said:
Got it working with firefox. went into plugins, made sure ESN SONAR API was on Always Activate and ESN Launch Mozilla Plugin was on Aways Activate (mine was not) restarted firefox and voila, all set



This is what I had to do for Chrome. @Op, have you checked any previous threads about windows plugins? I am sure when I was looking for my Chrome fix I saw a couple of IE fixes for it. Just enter any of the keywords into the box on the top right of the forums page and look for the latest postings.
One man's rubbish is another man's treasure, still kind of hard when you are told you are adopted. =)
watcher666
Enlisted: 2012-01-17
2013-11-05 22:01 , edited 2013-11-05 22:03 by watcher666
THIS IS TO GET THE PLUGIN FOR INTERNET EXPLORE TO WORK

open up internet explore

then head over to the symbols top right and click TOOLS symbols

then internet options

then head along to ADVANCED

then click on the reset button

a window will open up

then tick on the box DELETE PERSONAL SETTINGS at the bottom of that window

then shut down internet explore and reopen it again that how I got my plugin to work