Loading screen stuck

SE Enlisted: 2011-10-27
2012-03-20 21:48
Hi all!
Got a pretty anoying problem. When I'm trying to join a server I get the loading screen (were you see what mat it is etc), but the there should be a "black screen" with a white blinking dot in the bottom right corner. On that screen I get stuck.
I'we tried updating PB, tried multiple servers and my friends sees me online.
SO what could it be? Anyone got a solution?

Enlisted: 2011-12-17
2012-12-04 07:49
same problem on my end as well
sorry this was not a solution response
NO Enlisted: 2011-10-27
2012-12-04 07:52
TRying to play aftermath I presume? It's not available to play yet, you can't get in sedrvers with aftermath content.
PC SPECS: CPU: i7 3770 GPU: gainward Geforce GTX 670 RAM: 16 GB 1600 MHZ Cooling: Corsair H40 liquid-cooled cpu block. Motherboard: Asus P8Z77 Storage: Samsung SSD 128 GB & Western Caviar 1 TB HDD Case: CoolerMaster Storm Trooper
AU Enlisted: 2011-11-26
2012-12-06 05:18
well the aftermath servers are up and there are people playing in them, but I am also having this problem
Enlisted: 2011-10-25
2012-12-06 05:22
Having the same problem. Tried multiple servers, restarting the game, restarting the computer and still gets stuck on the loading screen. I even left it for about 20 minutes hoping it was just downloading something and still can't log in.
CX Enlisted: 2012-03-26
2012-12-06 05:27
Sign out of Origin and Battlelog, sign back in, then see if you can get past the loading screen.

That usually works for me when BF3 is being finicky.
CA Enlisted: 2012-03-27
2012-12-06 05:28
Ya that doesnt work. Ive tried.

Repairing install
Loading with internet Explorer
restarting Computer
Updating drivers
Signing out and signing back into Origin.
GB Enlisted: 2011-10-28
2012-12-07 00:38
I've had this issue, sign out of origin then sign back in, should eventually prompt you to download the final patch segment.