Extremely low FPS in Crossfire with 7970 Ghz Ed.

SergeantSteak
SE Enlisted: 2011-11-03
2013-09-04 18:44
Hello! I just built my new PC for battlefield 4 and i was playing the bf3 campaign just to get used to the controls and check how the computer performs. but all of a sudden when i am playing on ULTRA settings i get extreme low fps, sometimes it goes down to 12 fps for several seconds and sometimes it is stable on 60 FPS.

I have the following components in my PC:
CPU: intel I5 4670k @3.4
GPU: Gigabyte Radeon HD 7970 Ghz Edition ( i have two of them )
Mobo: GA-Z87X-OC
PSU: 750W 80+ Gold
RAM: 8Gb Corsair Vengeance.

I just don't know what is wrong, and i need help :(
I3oneface
CA Enlisted: 2011-10-24
2013-09-04 20:08
Are you using the 13.8beta drivers?
Intel i7 4770k @ 4.6Ghz, Asrock Z87 Extreme 3, Crucial Ballistic Sport 1600mhz @ 2000mhz, XFX R9 290@1157/1425 watercooled with Corsair H55, Samsung 840 120gig Ssd, Corsair H100 4x120mm fans, Asus Xonar D1 SC, Coolermaster GX750watt psu, Coolermaster HAF XB, Samsung S27A950D 120hz 3D
SergeantSteak
SE Enlisted: 2011-11-03
2013-09-05 07:27
I3oneface said:
Are you using the 13.8beta drivers?

I do not know, i'll check tomorrow on friday when i get back home. Do you mean the 13.8 Beta drivers for the mobo or the GPU's?
I3oneface
CA Enlisted: 2011-10-24
2013-09-05 13:41
For the video cards! It helps with the stutter from Crossfired cards!
Intel i7 4770k @ 4.6Ghz, Asrock Z87 Extreme 3, Crucial Ballistic Sport 1600mhz @ 2000mhz, XFX R9 290@1157/1425 watercooled with Corsair H55, Samsung 840 120gig Ssd, Corsair H100 4x120mm fans, Asus Xonar D1 SC, Coolermaster GX750watt psu, Coolermaster HAF XB, Samsung S27A950D 120hz 3D
SergeantSteak
SE Enlisted: 2011-11-03
2013-09-05 15:32
I3oneface said:
For the video cards! It helps with the stutter from Crossfired cards!

The thing is that it wasn't "stuttering" because it stayed solid on some levels for several seconds and stuttering doesn't typically do that so i though it wasnt microstuttering.
I3oneface
CA Enlisted: 2011-10-24
2013-09-06 06:18
Try the 13.10s
Intel i7 4770k @ 4.6Ghz, Asrock Z87 Extreme 3, Crucial Ballistic Sport 1600mhz @ 2000mhz, XFX R9 290@1157/1425 watercooled with Corsair H55, Samsung 840 120gig Ssd, Corsair H100 4x120mm fans, Asus Xonar D1 SC, Coolermaster GX750watt psu, Coolermaster HAF XB, Samsung S27A950D 120hz 3D
SergeantSteak
SE Enlisted: 2011-11-03
2013-09-06 13:39
I3oneface said:
Try the 13.10s

My current version on my drivers is : 8.982.0.0 updated in July 27th. If i press update drivers it says that it is already up to date.
I3oneface
CA Enlisted: 2011-10-24
2013-09-06 15:25
try these! http://www.techpowerup.com/downloads/2263/amd-catalyst-13-10-beta/ [techpowerup.com]
Intel i7 4770k @ 4.6Ghz, Asrock Z87 Extreme 3, Crucial Ballistic Sport 1600mhz @ 2000mhz, XFX R9 290@1157/1425 watercooled with Corsair H55, Samsung 840 120gig Ssd, Corsair H100 4x120mm fans, Asus Xonar D1 SC, Coolermaster GX750watt psu, Coolermaster HAF XB, Samsung S27A950D 120hz 3D
SergeantSteak
SE Enlisted: 2011-11-03
2013-09-07 08:12
I downloaded the drivers and so far ( about 4 hours of played time in multiplayer ) everything seems to work fine!
Thank you
I3oneface
CA Enlisted: 2011-10-24
2013-09-07 15:08
Np glad it worked for you!
Intel i7 4770k @ 4.6Ghz, Asrock Z87 Extreme 3, Crucial Ballistic Sport 1600mhz @ 2000mhz, XFX R9 290@1157/1425 watercooled with Corsair H55, Samsung 840 120gig Ssd, Corsair H100 4x120mm fans, Asus Xonar D1 SC, Coolermaster GX750watt psu, Coolermaster HAF XB, Samsung S27A950D 120hz 3D