BF4 Won't load what so ever

Jairza
GB Enlisted: 2013-05-19
2013-11-16 16:35
After trying to launch the BF4 campaign it opens up origin clod storage and closes. After this the blue bar at the bottom of the page says initializing but nothing happens.
I tried playing multi-player in which does the same thing and says joining server in which it is not. Anyone having this problem or got a solution to it? The game was running fine earlier
IAm_MADZ
SE Enlisted: 2011-10-29
2013-11-16 16:36
Try talk to ea online whahaha
Jairza
GB Enlisted: 2013-05-19
2013-11-16 16:39
Yeh that didn't help
IAm_MADZ
SE Enlisted: 2011-10-29
2013-11-16 16:42
yes u se, welcome to the crashfield community.. is could be the new patch.. Iam realy sorry
MiStErMTinhood
DE Enlisted: 2011-10-27
2013-11-17 12:42
i have the same problem! u got it fixed yet?
H1llaryClint0n
DE Enlisted: 2012-11-03
2013-11-17 16:06
same here, reinstalled bf4, updated pb, got the latest drivers, NOTHING worked
cant play multiplayer, test range wont load aswell as sp, fuck you DICE
crazy88boy
Enlisted: 2012-11-12
2013-11-20 00:28 , edited 2013-11-20 00:29 by crazy88boy
i tryed the same thing and i cant get on. like come on i did not pay for a 60$ game for it not to work after a patch.
H1llaryClint0n
DE Enlisted: 2012-11-03
2013-11-21 00:23 , edited 2013-11-21 00:27 by H1llaryClint0n
Maybe I'e found the solution for you guys, at least it did work for me.
It might be a problem with the Microsoft Visual C++ programs. I uninstalled all of them and after that I uninstalled BF4 as well as Origin (I dont know if you need to uninstall Origin, but I'd recommend it, just to be safe).
So after that, I just reinstalled at first Origin, then BF4, downloaded the patch, after that the browser plug in and as I tried to join a game, everything worked.
I'm not quite sure, if that will help you, since I don't know if you guys have the exact same problem as I had (I had the Blue Bar at the bottom of the browser where it's written "Joining Server" but nothing ever happens when trying to join a game), but you can give it a try.
Hopefully I've been able to help you.
Best regards.
densityy2k
Enlisted: 2011-10-25
2013-11-21 05:44
It got to be the stupid patch if we are all having the problem, after installing it. I'm not going through all that just to play a game. So screw you guys ea.