Thread is locked.

PC crashing issue workaround 25/02

EA_Rick
IE Enlisted: 2012-10-11
2014-02-25 12:10 , edited 2014-02-25 16:45 by EA_Rick
Hi everyone,

We are aware that some of you have been experiencing some crashing since the patch this morning. Below is a workaround for this problem:

1. Go into your game directory (dir:\Program files(x86)\Origin Games\Battlefield 4)
2. If you have a “user.cfg” file, open it in notepad.
3. Delete the command line “UI.DrawEnable 1”
4. Save the file
5. Start the game

If you do not have this file on your system but are still crashing please post here with details of what is happening so that it can be further looked into.

Thanks.

~Rick.
Need help? Twitter: @AskEASupport Facebook: http://www.facebook.com/AskEASupport For code/account issues, Contact Us at http://help.ea.com Want to be a hero? http://answers.ea.com Ask. Answer. Be the Hero! Need to contact me directly? PM EA_Rick on Answers HQ: http://answers.ea.com/t5/user/viewprofilepage/user-id/59804 Do not PM regarding ban appeals, direct these to accountdisputes@ea.com
PerryPlopper
GB Enlisted: 2011-11-09
2014-02-25 16:22
Thanks for putting the effort in to find this issue and solve it not even 24 hours after the patch, gj DICE, it might have taken a while, but you guys are really making some neat patches here. :)2
Gervan77
US Enlisted: 2011-10-25
2014-02-25 16:24
I installed patch 25 Feb, PC. Game crashes on load. Crash to desktop with "BF4 stopped working..." I tried above method, but only able to play 3-5 minutes before crash to desktop. I deleted "UI.DrawEnable 1". It works, again for 3-5 minutes before crashing. I notice that the command line 9UI.DrawEnable 1" gets put back into the file after each launch. Is this suppose to happen, or is it suppose to be deleted for good?
Sir-Kao-Pad
TH Enlisted: 2012-10-05
2014-02-25 16:27
This post has been removed by the Battlelog administrators.
SAYERET_13
IT Enlisted: 2011-10-29
2014-02-25 16:28 , edited 2014-02-25 16:28 by SAYERET_13
This post has been removed by the Battlelog administrators.
MiniChederz
Enlisted: 2014-01-04
2014-02-25 16:29 , edited 2014-02-25 16:29 by MiniChederz
Gervan77 said:
I installed patch 25 Feb, PC. Game crashes on load. Crash to desktop with "BF4 stopped working..." I tried above method, but only able to play 3-5 minutes before crash to desktop. I deleted "UI.DrawEnable 1". It works, again for 3-5 minutes before crashing. I notice that the command line 9UI.DrawEnable 1" gets put back into the file after each launch. Is this suppose to happen, or is it suppose to be deleted for good?


Try making the config file read only. (Right click on user.cfg and click properties). It might not help in the slightest but its worth a try.
LordBax81
IT Enlisted: 2011-10-28
2014-02-25 16:31
This post has been removed by the Battlelog administrators.
yOhylol
DE Enlisted: 2013-02-06
2014-02-25 16:32
I tried the method shown above, but the game is still disconnecting from the EA Server. It says: "ERROR You were disconnected from EA Online (1)". The game hit the loading screen (the black one, with the white stripes on the top right corner). It takes some seconds, then the game closes itself, and the error message "ERROR You were disconnected from EA Online (1)" is poppin up.
TGxthegamer
US Enlisted: 2011-10-24
2014-02-25 16:33 , edited 2014-02-25 16:35 by TGxthegamer
No user.cfg file in my folder. I keep getting this error: 'You were disconnected from EA Online (1)' . It happens right after 'Logging In'. Any fixes for this? And I have practically tried everything. BF3 works fine so I am sure I can 'log in' to EA Online.
Kikitu
ES Enlisted: 2011-10-26
2014-02-25 16:35
No file on my directory, tried everything and the game keeps crashing to desktop without battlelog errors, just "Bf4 stopped working"

I connect to a server, map loads, freezes at black screen before the battlemap load and crashes after that
EA_Rick
IE Enlisted: 2012-10-11
2014-02-25 16:36
Posts that are in breach of the forum rules will be censored and receive a temporary suspension.

Please make sure to keep your post constructive and on topic.

~Rick.
Need help? Twitter: @AskEASupport Facebook: http://www.facebook.com/AskEASupport For code/account issues, Contact Us at http://help.ea.com Want to be a hero? http://answers.ea.com Ask. Answer. Be the Hero! Need to contact me directly? PM EA_Rick on Answers HQ: http://answers.ea.com/t5/user/viewprofilepage/user-id/59804 Do not PM regarding ban appeals, direct these to accountdisputes@ea.com
lundqvist6138
IT Enlisted: 2013-07-02
2014-02-25 16:37
Mine passed from crashing in game with a freeze BSOD VIDEO_SCHEDULER_INTERNAL_ERROR to crashing (now with new patch) without EVEN getting into the game with the message

DirectX function "Get Device Removed Reason" failed with DXGI_Error_DEVICCE_HUNG: Device hung due to badly formed commands.. GPU:"Nvidia Geforce GTX 680", Driver 33489

Rampage Extreme IV LGA 2011 with Extreme processor, 32 GB RAM - completely water cooled with 2 loops - Nvidia 680s (never go beyond 40-45 C) 1200w PSU.
Mackkkk
BO Enlisted: 2011-10-26
2014-02-25 16:41
now work, before i have a blackscreen :D
Takushkanshkan
US Enlisted: 2011-10-24
2014-02-25 16:43 , edited 2014-02-25 17:16 by Takushkanshkan
crashing just started for me this morning too, 4 times in a row thus far...not had any issues before today. Not touching any files because in the past that has always created more issues than it solves....


`Alienware Aurora
i7 920 quadcore @ 2.67
two GTX 460 1gig in SLI
7 gig ram ddr3
Win 7 x64
850w psu

edit: repair install did not fix

edit: good grief! went to Campaign...not working either/ goes to black screen

EDIT: Workaround fixed problem. Always hesitant to even open and look at files (lol) ....should have listened to the blue box....see you on the battlefield!
xJensen1995
DK Enlisted: 2011-12-30
2014-02-25 16:45
Mine keeps crashing when i try enter a server.

it crash some times at the load screen and some times at the class selection. i have tried open some ports, repair the game and check for updates, but nothing help.
DVDFMerlin
IE Enlisted: 2011-11-01
2014-02-25 16:46
I've noticed that after the patch installed Origin became logged out and went offline. When logging in I could connect normally to the servers and didn't receive any ERROR You were disconnected from EA Online (1) warning thus far. Thought it might help.
Shveitsarets
KG Enlisted: 2011-11-13
2014-02-25 16:48
i am probably the only person who never had a single problem with bf4. now it wont even start. workarounds dont work
00Angelito00
HU Enlisted: 2011-10-31
2014-02-25 16:51
EA_Rick said:
Hi everyone,

We are aware that some of you have been experiencing some crashing since the patch this morning. Below is a workaround for this problem:

1. Go into your game directory (dir:\Program files(x86)\Origin Games\Battlefield 4)
2. If you have a “user.cfg” file, open it in notepad.
3. Delete the command line “UI.DrawEnable 1”
4. Save the file
5. Start the game

If you do not have this file on your system but are still crashing please post here with details of what is happening so that it can be further looked into.

Thanks.

~Rick.



thanks, it works for me.
Kaaz29
US Enlisted: 2011-10-25
2014-02-25 16:52
The above work around works for me so far.... will edit if things change.
Frikster0202
ZA Enlisted: 2012-12-23
2014-02-25 16:53
Hi Guys.

Ok so i have all the latest driver, updates etc.

Game starts up nice and whilst playing just freezes the screen and there it will stay freezed till you hard reset your pc.

Any idea what to do?
 
Thread is locked.
Thread is locked.