MSVCR110.dll error, updated everything still crash

US Enlisted: 2011-10-25
2013-11-02 21:16 , edited 2013-11-02 21:17 by Drakavon
This is the 3rd fucking time today I've had a crash while changing maps. I swear to god I can't even play a whole game without a problem! Campaign sucks and it's the only part of the game that's worked semi-perfectly so far.

Absolutely infuriated.

Here's the error code:

Problem Event Name: APPCRASH
Application Name: bf4.exe
Application Version:
Application Timestamp: 526b9042
Fault Module Name: MSVCR110.dll

THIRD TIME. Same thing every time. Tried updating DirectX, tried updating punkbuster (both from the BF4 install folder in "Origin Games"), drivers are up to date all around. I mean what the hell am I left to do???


AMD Phenom II quad core 3.4 black ed (overclocked to 10%)
8GB Ram (2x4gb 1333mhz both sticks)
DE Enlisted: 2012-09-05
2013-11-05 01:51
Same here
US Enlisted: 2011-10-25
2013-11-06 02:04
Bump? Anyone? I'm not the only one...
KR Enlisted: 2013-10-29
2013-11-06 02:26
Same here... crash while changing maps
US Enlisted: 2011-10-26
2013-11-06 04:07
Check out []

Did you do this?
Darwin's theory is no longer relevant, only the stupid and weak are breeding
AU Enlisted: 2014-07-22
2015-01-02 13:10 , edited 2015-04-12 04:24 by NamelessHenchman
I think I fixed it.

There is a new update of Visual Studio 2012 redistributable. Download it and run depending on the version of Battlefield 4 you are running (X64 or X86) []

Make sure it matches the version of BF4 you are running - []

Should work