Bf4 Stuck on Loading Level & white Screen

Azzkikr18
Enlisted: 2012-10-07
2013-10-05 17:21
Slade122 said:
Loading Levels in BF4 took a long time, even with my pair of Vertex's in RAID 0. Using a 1090T/8GB RAM/2 x 6970 CF. Memory usage went over 5GB... Game plays fine otherwise. My only issue is that I can't fullscreen.

try pressing alt+enter
Repp3
Enlisted: 2011-12-26
2013-10-05 20:56
right click on the game and update it
jordy2211221
Enlisted: 2013-03-28
2013-10-05 21:02 , edited 2013-10-05 21:03 by jordy2211221
Facerr said:
It doesnt work for me either, but i dont care. Its not like i wont buy the full version.. all the mongrels here whining about not buying it is all bullshit anyway.. Just buy a better pc and shutup ^^...




Well, not everyone can afford to buy a new PC here... even if we chose it over consoles.
Inf1n1tyNL
Enlisted: 2012-02-02
2013-10-05 21:03
I managed to fix looping sound/hang on BF3: I was using RemoveWAT for Windows (activation software) that came shipped with my version, and when I removed it it fixed the looping sound/game hang/computer freeze for me!

I think it's maybe the same issue, if you're using this might want to remove it.
DellanP
US Enlisted: 2012-03-04
2013-10-06 00:35
reinstalled the game, reinstalled PB and updated windows and drivers..what next to stop the load screen Freeze
Fear not what you can see........ Fear what you cannot
Ray-Ray72000
CA Enlisted: 2013-10-05
2013-10-06 00:38
This is the exact problem im having it will not start it stays on the loading stage for about 2-4 mins then it freezes i esc and it says it stops working i did all the soulotions its really annoying thanks ea
fluoridezombie
Enlisted: 2013-10-06
2013-10-06 03:07
i read countless threads about this and it has to do with windows 7 game only works on 8. considering that almost all pc gamers use windows 7 this is a huge fuck up im not buying game now and they can lick my balls.
Turtle_Sweg
Enlisted: 2012-08-27
2013-10-06 04:09
antoyno said:
Hey everybody, i saw this:

"SOLUTION TO STUCK ON WHITE/BLACK/LOADING SCREEN



1 Exit / End Task for BF4 and Close Origin
2 Open Windows Explorer to: C:\Program Files (x86)\Origin Games\Battlefield 4 Beta\__Installer\directx\redist
3 If you don't have an Origin Games folder, try looking for the Battlefield 4 Beta folder under C:\Program Files (x86)\Origin, worst case, do a search on your C:\ drive for "Battlefield 4"
4 Create a new folder called "files"
5 Cut and Paste all files except DSETUP.dll, dsetup32.dll, dxdllreg_x86.cab and DXSETUP.exe into the newly created "files" folder (i.e: this redist directory will only have the 4 files mentioned above, everything else will now be in redist\files)
6 Right click on Origin shortcut and choose "Run as Administrator"
7 Right click on BF4 beta in your games list and choose "repair install"
8 Once repair is complete, launch the game and it should run fine.
9 Enjoy"

Credits: http://www.nononsensegamers.com/forums/threads/battlefield-4-loading-bug-issue-fix.3417/ [nononsensegamers.com]

I tried this 3 times and all it does is put all the files back in the original place when you repair install :

I'm going to see what happens


I've got the same problem I have tried almost everything to stop the loading screen bug but nothing seems to work for me.

I tried this 3 times and all it does is put all the files back in the original place when you repair install :/
Eshkin-Kat
UA Enlisted: 2013-04-29
2013-10-06 04:16
fluoridezombie said:
i read countless threads about this and it has to do with windows 7 game only works on 8. considering that almost all pc gamers use windows 7 this is a huge fuck up im not buying game now and they can lick my balls.

nope. I have the same problem on Windows 8.
Turtle_Sweg
Enlisted: 2012-08-27
2013-10-06 04:20
Eshkin-Kat said:
fluoridezombie said:
i read countless threads about this and it has to do with windows 7 game only works on 8. considering that almost all pc gamers use windows 7 this is a huge fuck up im not buying game now and they can lick my balls.
nope. I have the same problem on Windows 8.


same I have windows 8 and the loading screen still fucks up ARRRRRRGH.
Xeroed7
IN Enlisted: 2013-05-30
2013-10-06 06:10
I understand that the game is in Beta. But fuck, it is meant to be played, it is Open after all. And it contains gamebreaking bugs like this one.
DICE created a Open beta which doesn't even Open.

GG dice
WorldofJuice
ZM Enlisted: 2012-10-05
2013-10-06 07:05
The game finally worked after I switched to my Intel HD graphics card. It works at 20+
you can view it here:

https://www.youtube.com/watch?v=xwsgCllo7OY [youtube.com]


I already tried it on my 750M but it didn't work :P
Shnukumz
IT Enlisted: 2013-10-05
2013-10-06 08:27
Same problem.

Laptop:

Windows 8
8GB RAM
GT 750M 2GB VRAM
Intel HD 4600

Probably the system is not switching to the GeForce...

All drivers are of course up to date.
XEGP-Swainix
Enlisted: 2012-11-28
2013-10-06 09:15
I tried everything... I think my problem is my dual coree intel core 2 duo..; Everyone has this problem with it... DICE FIX THIS PROBLEM HOLY S*** !!
Swainix, joueur sympa qui fait n'importe quoi !
xYohki
Enlisted: 2013-07-26
2013-10-06 12:51
i have the same problem is it because of my core 2 duo E8400 3.00 GHZ ?
NethanIKEA
TH Enlisted: 2013-01-03
2013-10-06 15:06
i think dual core cannnot running this game
peanutbutterxxJ
GB Enlisted: 2013-05-06
2013-10-06 15:10
this is some kind of bad joke hope everyone cancels there preorder an gets money back fuck you EA an DICE aswell!!!!
SeventeenV
AU Enlisted: 2011-12-01
2013-10-06 15:41
Intel Core 2 Duo E8600
GTX 760 2GB

Naddah luck. Same issue. Dual core CPU.
suore
Enlisted: 2013-08-18
2013-10-06 15:57 , edited 2013-10-06 15:58 by suore
I have same problem.

OS:
Windows 7 Professional 64-bit SP1
CPU
AMD Athlon II X2 245
Technology Regor 45nm
RAM
4,00GB 2-channel DDR3 @ 535MHz (8-8-8-20)
Motherbpard:
Gigabyte Technology Co., Ltd. GA-MA785GT-UD3H (Socket M2)
GPU
1024MB NVIDIA GeForce GTS 250
hici2033
HU Enlisted: 2011-11-18
2013-10-06 16:01
i have the same problem BUT:

Os: Win 7 64 bit
CPU:
AMD FX-6200 6core 3.8 ghz
8 gb 2400mhz ram
ASUS RADEON HD7870 DIRECT CU 2 videocard

and still crashing