Thread is locked.

DirectX function "device->CreateBuffer(..)" error

NL Enlisted: 2011-10-26
2013-10-01 12:05 , edited 2013-10-01 12:32 by edinition
I get this error when starting the game: []

which says:

DirectX function "device -> CreateBuffer(&dxDesc, 0, &buffer->m_buffer)" failed with E_INVALIDARG ("An invalid parameter was passed to the returning function"). GPU: "Intel(R) HD Graphics 3000", Driver: Unknown.

My setup is as follows:
Windows 7 Professional 64bit
Intel Core i7-2630QM CPU
8GB of RAM
NVIDIA Quadro 1000M

I installed the latest NVIDIA drivers (320.86) and even tried the latest Beta drivers (331.40), without any success (even with a clean install). I additionally tried to repair my BF4 Beta installation through the Origin client, reinstalled DirectX, did a repair of my Visual C++ redistributable (vcredist_x64), but in all cases with no success.

Does anyone have any solution to this?

I solved the issue by just disabling the integrated card. In my case in the BIOS settings instead of NVIDIA Optimus I selected Discrete graphics. The problem seems solved and the game is running as it should. Hope this helps others too.
US Enlisted: 2011-10-24
2013-10-01 12:06
Having same issue. Did both drivers.
Enlisted: 2011-10-28
2013-10-01 12:08
Me too, can't play at all.
Enlisted: 2013-06-12
2013-10-01 12:09 []

Same deal here man.
PL Enlisted: 2011-10-26
2013-10-01 12:21
This error looks like a bit code-based to me...

Anyway, this "GPU: "Intel(R) HD Graphics 3000"" part is interesting... do you have mainboard with integrated GPU? If yes, do you have the GPU switched off under BIOS settings? (there should be such option).

I think that BF4 detects that integrated GPU during device enumeration and tries to run on it instead of your "main" GPU. Switching it off under BIOS should remove it from devices detected by OS... and also by the game.
US Enlisted: 2011-10-24
2013-10-01 12:23
It seems to be running now with the 331.40 beta driver.
Enlisted: 2011-12-26
2013-10-01 12:50 []
PT Enlisted: 2013-09-24
2013-10-01 13:14 , edited 2013-10-01 13:36 by Y05H1M1T5V
AmokzwiebelSwiSs said: []

that is for


not for E_INVALIDARG ...

i have same problem here

drives 13.1: []
drives 13.4 beta: []

i have
Radeon HD 4670 512mb
Win 7 ultimate x64
4Gb ram

EA Topic: []
mark that you have that problem .. is better have only one topic than 50 .. XD
DE Enlisted: 2011-10-24
2013-10-01 13:25 , edited 2013-10-01 13:30 by Rand0m-Walk
I have the same problems with catalyst 13.1 and 13.4 with Radeon HD 4600 series, Win 7 x64 and 4 GB ram as reported by Y05H1M1T5V.
SE Enlisted: 2011-10-27
2013-10-03 18:29 , edited 2013-10-03 18:29 by BigBadSwarley
I have the same issue with my GPU, worked fine yesterday after driver update but not today. AMD Radesn HD 5800 series, Win 7 x64, 6 GB ram,
Everything is upated to latest uptade even Windows uptades can't find any more updates. Useing the beta driver 13.10 2beta
There is no tiny fucking unicorns squeezing out rainbow coloured assclouds to blow your head off, it's just me.
Enlisted: 2013-01-04
2013-10-07 03:22
Same Directx problem here. I have Radeon 4600, with Windows 7 64bit, AMD Catalyst 13.4 Beta
US Enlisted: 2012-08-08
2013-10-07 03:24
Good thing this was optimized for AMD hardware.....LOL so sad....glad I have a GTX 670. Been playing since the first. No I'm not trying to rub it in, just emphasizing the fact that DICE are pricks to do this to people. :(
US Enlisted: 2013-06-16
2013-10-13 22:59
I have Same issue, same error.

Radeon HD 4650
Intel Dual Core
Enlisted: 2013-11-08
2013-11-08 20:59
same issue here... ATI RADEON HD 4800 SERIES..
PL Enlisted: 2011-12-27
2013-11-12 14:28
samee here GFforce GT555M
Enlisted: 2013-11-29
2013-12-12 01:46
Same here newest Driver and GTX 680!
RU Enlisted: 2012-01-23
2015-02-08 22:00
same GTX 660Ti
KR Enlisted: 2012-06-09
2016-01-14 02:13
same GTX 560 !
Thread is locked.
Thread is locked.