BF4 Browser plugin doesn't install in windows 8.1

BratuPetre
TR Enlisted: 2012-12-12
2013-11-07 21:02 , edited 2013-11-07 21:13 by BratuPetre
Same here. Nothing changed even closing defender, firewall etc.

Edit: Reinstalled Origin and fixed.
FaluKaka
SE Enlisted: 2013-10-05
2013-11-08 07:27 , edited 2013-11-08 07:27 by FaluKaka
same thing here i have windows 8.1 pro and i cant play bf4 i have downlowded punkbuster and chek for updates but cant find updates and i have reinstalled bf4 and orgin and it dont work! HELP SOMEONE???
Yashsingh10
IN Enlisted: 2013-11-02
2013-11-08 09:31
i bought bf4 deluxe edition, then tried to launch multiplayer i said to install battlelog plugin , i installed it but when i tried to play again that dialouge box appeared again and again plz help me . Windows 7 using chrome
efcjoh
Enlisted: 2011-11-08
2013-11-08 11:26
BF4 was working fine with W8 and chrome now today wont run because of the plugin issue. i bought deluxe pack.. please resolve or give me my money back. really PO
Criciious
Enlisted: 2011-12-29
2013-11-08 13:43
same thing happens to me! come on then DICE and EA!
CeltS_Puggy
Enlisted: 2011-10-29
2013-11-08 13:51
im using chrome and win7 64 bit what i did to get it working was Uninstall Battlelog Web Plugins , under uninstall programs, reinstalled when starting game and it all worked
frightner24
US Enlisted: 2012-05-15
2013-11-08 14:59
gosh i hate battlelog makes things such a pain to join games :( downloaded chrome but now it crashes... if i cant get it working soon im going to get my money back from orgin
Dale_Nav13
Enlisted: 2013-11-08
2013-11-08 20:49
I HAVE THE EXACT SAME PROBLEM ! SUCH BULLSHIT !!
L3SsBr0
DK Enlisted: 2011-10-27
2013-11-08 21:56
shit same same :(
muchwin
DE Enlisted: 2011-10-26
2013-11-08 23:06 , edited 2013-11-08 23:24 by muchwin
Same problem, all "fixes" won't do it.

It work's in Internet Explorer though. Try it guys!

EDIT: Just realized I needed to disable Windows Defender Real Time Protection to make it work in Internet Explorer
Diagorias
NL Enlisted: 2011-10-26
2013-11-09 00:21 , edited 2013-11-09 00:22 by Diagorias
For me it worked to run the .exe file, restart my pc and then try to start the game in battlelog. Hope this helps you all. (Firefox, Windows 8.1)
Bradyator
IE Enlisted: 2012-12-13
2013-11-09 02:12
If you're using Internet Explorer

1. Click on the gear cog on the top right and select Internet Options.

2. Select the Security Tab on the pop-up

3. Select the Trusted Sites, green tick

4. Click on the Sites button under the green tick

5. Untick 'Require server verification...'

6. Copy this into the 'Add this site to the zone' dialog: http://battlelog.battlefield.com/bf4/ [battlelog.battlefield.com] and click Add

7. Retick the 'Require server verification...' tickbox

8. Close the browser and then launch BF4.
P3RSI4ND4GG3R
CA Enlisted: 2011-12-24
2013-11-09 02:50
just disable Protected Mode OFF , you should see it right side of bottom of your internet explorer, go to internet options, then Security Tab, uncheck protected mode and bring your security to low to accept cookies and shit... just a little added security from windows 8.1 which is good if you watch porn lol nothing else.
ULTIMATEFUGE
ES Enlisted: 2011-12-25
2013-11-09 02:54
That happened to me, and I fixed it. I don't remember exactly what I did but I think I went to "C:\Users\*your window's user name*\AppData\Local\Temp", and then run sonarinst.exe, installed it, and restarted chrome.

Good luck.
Best Europe server: http://battlelog.battlefield.com/bf3/servers/show/pc/3ec302f1-2fcb-4ee4-88b5-36fb6ee697c3/METRO-24-7-NO-EXPLOSIVE-NO-SHOTGUNS-FULLY-ADMINED-BY-UWAR/
CharmedIII
Enlisted: 2012-06-01
2013-11-09 03:44 , edited 2013-11-09 03:45 by CharmedIII
I just simply uninstalled Battlelog Web Plugins via "Programs and Features" then restarted using google chrome and re-installed plugin, works a treat.
PapaSobrio
US Enlisted: 2013-06-19
2013-11-09 04:36
I really hate this. Why do they have to make it so complicated. Just let me play the freaking game. Wow. So frustrating.
AngelDeath82
CA Enlisted: 2011-10-25
2013-11-09 05:34
Working with IE 10 on Win 7 x64, but not with IE 11 on same system.
Lt_Baggins
Enlisted: 2011-11-06
2013-11-09 15:30
I had the same problem after installing Windows 8.1. I disabled Windows Defender and that did the trick.
NexxusCloud
US Enlisted: 2013-11-08
2013-11-09 19:29
Hey guys, you don't need to disable real time protection, (18 years of corporate IT experience here). This is what you need to do. At least this will work for Windows 8 and Windows 8.1 with IE 10 or IE 11. I'm not sure about Win 7 as I didn't bother to test it however I'm sure it will work for you Win7 people too. 32 and 64 bit doesn't matter here.

The reason why Windows Defenderr real time protection seems to be the issue is how it works in tandem with IE and it's protections. I'm also not running anything in Admin mode or any other BS like that. So I'm running Origin in regular mode with no tweaks, installed both in the default area on one computer and a custom area in another so for all you SSD guys out there that say, what if I have it installed in X, it doesn't matter.
All you really need to do is to:

1. Launch Origin or BF4
2. Go to the gear at the upper right section of your IE, you are looking to get into "Internet Options"
3. Go to the security tab
4. Click on Trusted Sites, drop the Security Level slider down to Medium-Low.
5. Click on the sites button below it
6. If it doesn't already put this in there for you, type / copy this into your "Add this website..."
http://battlelog.battlefield.com [battlelog.battlefield.com]
7. Uncheck the box "Require server verification" as battle log doesn't run in HTTPS
8. Click on the "Add" button and it will appear in the lower box of "Websites:"
9. Close
10. The next thing I do is take IE out of "Protected Mode" Protected mode is a joke and basically makes your internet browser useless on many sites. You will not really be opening yourself up to more than normal however this alone is not enough to make BF4 run.
11. Once I do that, OK yourself out of IE options

You will want to close ALL IE browser windows. You need a complete restart of IE, not your computer but all IE browsers need to be closed and re-opened.

Launch Origin or BF4 how you normally would and check it out. All good.

Simple as that.
PedroEglasias
Enlisted: 2011-10-26
2013-11-10 01:04 , edited 2013-11-10 01:07 by PedroEglasias
Windows 8 - Wouldn't work at all, restart, run plug-in with defender disabled etc.. Launched first go on IE10.


NexxusCloud said:
...Simple as that.


11 steps to launch a game isn't anywhere near as simple as it should be.

Really wish they hadn't gone with the f2p styles browser based system.