Possible SLI Flickering Fix - Post Dec. 16 Patch

im_defter
US Enlisted: 2011-11-16
2013-12-16 23:54 , edited 2013-12-17 00:11 by im_defter
one way i found to get rid of the flickering was to "force alternate frame rendering 2" in the nvidia control panel. however, the down side to this is that i noticed quite a massive fps drop in the "out of bounds" areas and while navigating through the loadout menu. but, it did get rid of the flickering for me 100%.

if the flickering is really bothering you to your limits, then go ahead and try this.

as for Crossfire users, i can't say if the same will work for you guys but, i'm not exactly sure why nvidia's SLI rendering mode, AFR2, gets rid of the flickering altogether in the first place. if you guys find/know of a similar setting than go ahead and try it out.

- just on a side note: SLI AFR2 still uses both GPUs so you won't have to worry about disabling SLI and etc.

i'm using 331.82 WHQL drivers.
i7 3770k
GTX 670 2GB SLI
Win8 Pro
Xzeco
GB Enlisted: 2011-10-24
2013-12-16 23:55
Ive done this and it works fine! nice one!
Kodo45
Enlisted: 2011-12-28
2013-12-16 23:57
The question is... Why did they make it to where it flickers in the first freaking place?????
im_defter
US Enlisted: 2011-11-16
2013-12-16 23:58
Kodo420 said:
The question is... Why did they make it to where it flickers in the first freaking place?????


that is indeed the question :/
HappyK1LLMore
US Enlisted: 2011-10-24
2013-12-17 00:00
That's easy.

BF4 is a console joke to the PC. Since consoles don't have SLI / Crossfire capability, DICE accidentally left dirty console peasant code in the PC release.

Thus, if you are using more than 1 card, you are part of the console joke from EA.
   ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​   ‎‏​    got ρЯΞΜΙUΜ?   ‎‏​       ‎‏​       ‎‏​       ‎‏​         ‎‏​    
DKD46041-DMN-
GL Enlisted: 2011-10-25
2013-12-17 00:01
Confirmed, this removes the flicker; although now all the textures are just missing.
theJ3w
GB Enlisted: 2011-10-24
2013-12-17 00:02
I just disabled one of my 280xs while they fix it. Still getting 80 - 100 fps all ultra.
i7 4770K @ 4.6Ghz - Corsair H80i : Coolermaster Cosmos S : Gigabyte Z87X UD3H : 2 x R9 280X Vapor-x Crossfire : 1000W Silverstone PSU : 2 x 24" Full HD Monitors : 12gig G-Skill DDR3 : 12+TB Sata3 HDD Space : 120Gig Samsung SSD : X52 Joystick : Logitech G25 wheel : Fatality Headset : Deathadder Respawn : MS Natural 4000 Keyboard : Windows 8.1 Pro
mlndbomb
US Enlisted: 2013-11-29
2013-12-17 00:02
Kodo420 said:
The question is... Why did they make it to where it flickers in the first freaking place?????


There was small flickering before that effected everyone. They fixed this, but the fix was incompatible with AFR which is used by crossfire and SLI.
im_defter
US Enlisted: 2011-11-16
2013-12-17 00:04
DKD46041-DMN- said:
Confirmed, this removes the flicker; although now all the textures are just missing.


are you saying that your terrain decoration is gone? and the ground looks like its a single color?

if so, i noticed this even with the nvidia SLI recommended setting so it's probably a bug that was introduced with the patch as well.
D1mMaK
US Enlisted: 2011-10-24
2013-12-17 00:04
defterOD said:
one way i found to get rid of the flickering was to "force alternate frame rendering 2" in the nvidia control panel. however, the down side to this is that i noticed quite a massive fps drop in the "out of bounds" areas and while navigating through the loadout menu. but, it did get rid of the flickering for me 100%.

if the flickering is really bothering you to your limits, then go ahead and try this.

as for Crossfire users, i can't say if the same will work for you guys but, i'm not exactly sure why nvidia's SLI rendering mode, AFR2, gets rid of the flickering altogether in the first place. if you guys find/know of a similar setting than go ahead and try it out.

- just on a side note: SLI AFR2 still uses both GPUs so you won't have to worry about disabling SLI and etc.

i'm using 331.82 WHQL drivers.


I did this and did not notice an FPS drop at all. Flickering is gone.
HappyK1LLMore
US Enlisted: 2011-10-24
2013-12-17 00:04
mlndbomb said:
Kodo420 said:
The question is... Why did they make it to where it flickers in the first freaking place?????
There was small flickering before that effected everyone. They fixed this, but the fix was incompatible with AFR which is used by crossfire and SLI.


Thus resulting in the question why was the fix incompatible with the AFR...? Because consoles don't use AFR. Why would they...
   ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​       ‎‏​   ‎‏​    got ρЯΞΜΙUΜ?   ‎‏​       ‎‏​       ‎‏​       ‎‏​         ‎‏​    
im_defter
US Enlisted: 2011-11-16
2013-12-17 00:09
D1mMaK said:
defterOD said:
one way i found to get rid of the flickering was to "force alternate frame rendering 2" in the nvidia control panel. however, the down side to this is that i noticed quite a massive fps drop in the "out of bounds" areas and while navigating through the loadout menu. but, it did get rid of the flickering for me 100%.

if the flickering is really bothering you to your limits, then go ahead and try this.

as for Crossfire users, i can't say if the same will work for you guys but, i'm not exactly sure why nvidia's SLI rendering mode, AFR2, gets rid of the flickering altogether in the first place. if you guys find/know of a similar setting than go ahead and try it out.

- just on a side note: SLI AFR2 still uses both GPUs so you won't have to worry about disabling SLI and etc.

i'm using 331.82 WHQL drivers.
I did this and did not notice an FPS drop at all. Flickering is gone.


awesome, glad it worked out :)
noobarse
Enlisted: 2013-12-05
2013-12-17 00:32
defterOD said:
D1mMaK said:
defterOD said:
one way i found to get rid of the flickering was to "force alternate frame rendering 2" in the nvidia control panel. however, the down side to this is that i noticed quite a massive fps drop in the "out of bounds" areas and while navigating through the loadout menu. but, it did get rid of the flickering for me 100%.

if the flickering is really bothering you to your limits, then go ahead and try this.

as for Crossfire users, i can't say if the same will work for you guys but, i'm not exactly sure why nvidia's SLI rendering mode, AFR2, gets rid of the flickering altogether in the first place. if you guys find/know of a similar setting than go ahead and try it out.

- just on a side note: SLI AFR2 still uses both GPUs so you won't have to worry about disabling SLI and etc.

i'm using 331.82 WHQL drivers.
I did this and did not notice an FPS drop at all. Flickering is gone.
awesome, glad it worked out :)


Sorry don't work, don't know why it works for some.
Zurv
US Enlisted: 2011-10-24
2013-12-17 00:34 , edited 2013-12-17 00:51 by Zurv
Set lighting to low.. that should fix the issue..


nope... this fixed a blinky issue in single player, but didn't help with the ground blinking in multi... sorry :(
NVidia Titan Quad SLI (watercooled), 32" Sharp UltraHD pn-k321 (3840x2160) Asus Rampage IV Extreme, i7-4930k (6 cores) 4.7ghz (water cooled) 1866 DDR3 (32gigs Quad channel), Seasonic 1250 Watt PSU Samsung 840 pro 128 SSD (system drive), OCZ 512 Vector SSD x2 (raid 0), Samsung 840 1TB SSD Logitech G19s / G9, wired 360 controller audio: Audiolab M-DAC -> Rega Brio-R (AMP) -> Sennheiser HD800 (headphones) or PSB imagine mini (speakers) Windows 8.1 x64
LevelEndBaddie
GB Enlisted: 2011-10-25
2013-12-17 00:45
Zurv said:
Set lighting to low.. that should fix the issue

nope
| AMD FX8350 @ 4.8ghz | Asus R9 290 DCUII | ASUS Sabertooth 990FX R2.0 | 8gb Corsair Vengeance 1866mhz | Logitech G500s | Corsair Vengeance K70 | Corsair Vengeance C70 | Corsair H100i | Corsair AX860 | Win 8.1 64 bit | BenQ XL2411T 24" 144Hz |
Johnny5fodder
CA Enlisted: 2011-10-24
2013-12-17 00:50 , edited 2013-12-17 00:51 by Johnny5fodder
Win 8.1 SLI 670's 331.82. Tried every SLI setting and none of them fix the issue.

And they still haven't fixed the terrain decoration bug whereby it need to be set on med for ultra settings. Seriously.
im_defter
US Enlisted: 2011-11-16
2013-12-17 00:57
Johnny5fodder said:
Win 8.1 SLI 670's 331.82. Tried every SLI setting and none of them fix the issue.

And they still haven't fixed the terrain decoration bug whereby it need to be set on med for ultra settings. Seriously.


hmm, imma have to try out medium settings and see if i get similar results.

as of right now, it looks like i get no terrain decoration at all on Ultra or Low.
D1mMaK
US Enlisted: 2011-10-24
2013-12-17 02:04
I hate rigging things to make them work. We shouldn't have to do this. Hopefully, they fix this issue soon.
phprof
US Enlisted: 2011-10-27
2013-12-17 02:05
Don't SLI. That's an easy fix.
D1mMaK
US Enlisted: 2011-10-24
2013-12-17 02:08
phprof said:
Don't SLI. That's an easy fix.


That's just dumb. If you had SLI, would you settle for "just don't SLI?"