Thread is locked.

Bf4 Stuck on Loading Level & white Screen

ReauxNL
NL Enlisted: 2013-11-30
2014-09-05 21:11
yea...

uhm guys,

If you send a mail to support or something they will help you with all there pleasure.
Please dont be so negative or tell me the name of a game that doesnt have 1 bugg or issue like this.

Thx,

Reaux
Vivaldin
Enlisted: 2011-12-30
2014-09-06 21:13
Its MSI Afterburner.
Turned it off and game works again.
drtrakianboy
TR Enlisted: 2013-12-21
2014-09-09 21:32
Vivaldin said:
Its MSI Afterburner.
Turned it off and game works again.

I agree,but do you know any other programs like afterburner ? I manage my fan settings with it
Gypt2
Enlisted: 2013-11-07
2014-09-12 05:49
.... I shouldn't have to mess with the game files just to get it to work, can't believe this sort of thing isn't fixed by now.
Rivid
PL Enlisted: 2011-10-25
2014-09-14 09:13
f this i can't play this f game! WHy this f white shit always appear?!
Mr_RhinoCeros
Enlisted: 2012-10-04
2014-09-26 16:18
no solution for me here. updated punkbuster, updated graphics driver and disabled origin!. no results. still stuck in "Level loading" ....any suggestions?
If everything seems under control, you're just not going fast enough. (Mario Andretti)
alroar
VA Enlisted: 2011-10-25
2014-09-26 22:23
Nah this is getting ridiculous....

I guess EA cut mist money, hence coders from BF4, since it´s not throwing out any income anymore. The Buglist is insanely-long.

For myself, i´m trying to play a round of bf4 for the first time in 3 months and it´s not working. After something 2-3 weeks i got it to work. But seriously, is that what i have todo as a casual gamer? seriously...
KILLERKRALLE001
DE Enlisted: 2014-05-29
2014-09-27 12:45
Vivaldin said:
Its MSI Afterburner.
Turned it off and game works again.

thanks very much!
50L0M0N
DE Enlisted: 2011-10-26
2014-09-28 18:47
FreshPrince2k9 said:
It seems to be a problemn with RTSS (Riva Tuner Statistics Server) in combination with the new Afterburner 3.01.
I installed an older RTSS but that did not fix it. So it is an issue with Afterburner 3.01 with RTSS being active.

I updated it a few days ago, since then I did not play BF4.
Yesterday I installed Hardline Beta and had the issue, that it gets stuck at loading. It is also known, when you google it. Nothing helped to fix this, so I uninstaleld it and today I wanted to start BF4 and suddenly I had the same issue!
While loading at the beginning I had 30 fps and then it broke down to about 1-3fps. Unplayable.
With Hardline was the same thing, but there I had 0 fps at the end with the black screen.

After disabling RTSS, Framerate Logging, and all other OSD Features of Afterburner, at least BF4 starts without problems.

Is it probably the same issue with Hardline?
I will test it later, when I reinstalled it.


Is the new Afterburner probably also the issue causing the "We are investigating a recent unwarranted PunkBuster ban. We are working to resolve the issue as soon as possible. Thank you for your patience." message?


Sorry for no perfect English ;)


This one helped me! Thanks! Disable the RTSS OSD logging in Afterburner.
GHOST_INGENIUM
UA Enlisted: 2013-07-19
2014-10-01 18:18
+100
SovietPacman said:
Why can't dice fix anything? I guess this is a lesson to us all to never buy their products again...
BanimalDrown
US Enlisted: 2014-02-12
2014-10-07 19:30
I keep getting a game crash 5 mins into a match. Tried disabling origin in game and all the other fixes so far. Nothing is working!!!!









i54690k 12gb cossair vengence ram radeon r9 270x
chickenhyphen
US Enlisted: 2011-10-26
2014-10-15 08:08
I can confirm this is MSI Afterburner causing this (well, it works fine with every other game, just not BF4, go figure).

Open RivaTunerStatisticsServer and add BF4.exe to the list, then set it's Application detection level to None.
signalfire85
US Enlisted: 2012-05-26
2014-10-19 06:43
chickenhyphen said:
I can confirm this is MSI Afterburner causing this (well, it works fine with every other game, just not BF4, go figure).

Open RivaTunerStatisticsServer and add BF4.exe to the list, then set it's Application detection level to None.


Tried this and it worked. Closing RivaTuner didn't do the trick (including MSI afterburner), but this did. I included both bf4.exe and bf4_x86.exe just to make sure. I almost gave up and was willing to wait for the next patch to see if that would do the trick. Finally been able to play a game in over a month. Ever since the new patch, I would be stuck on 'loading level' with a white screen. RivaTuner for some reason works fine on BF3 though.
xS4E3Dx
Enlisted: 2013-09-29
2014-11-05 19:10
same problem in bf4 :/
187Makaveli187
Enlisted: 2014-11-07
2014-11-15 21:33
Hold down the Windows key and press R. (This will open the Run dialogue.)
Type msconfig and press Enter.
In System Configuration, select the Tools tab.
Select Change UAC Settings and click the Launch button.
Pull the level to the down position Never Notify and click the OK button..

Restart your pc after.!!!!!!!

This worked for me,mabey it also works for you.

Give it a try.

Greetz,

Chicken
NemmePC
GB Enlisted: 2014-10-31
2014-11-16 09:02
Ive tryed most, if not all ways but it still wont work!
xChickenBOSSx
SI Enlisted: 2014-12-07
2014-12-08 17:47
Guys please i did not manage to find solution yet. I tried all of the things you said and..... still the same.
Can someone help me please?
I did not download Bf4 from Origin if that's a problem?
RavenousNuNu
Enlisted: 2013-10-15
2014-12-28 05:40
SAME HERE!
_-Ascension45-_
US Enlisted: 2014-12-30
2015-01-07 21:47
Having this same problem white screen, or the game minimizes and when I click BF in system tray it just does not pop up, or goes to the white screen of death. Tried every 'solution' in this thread and still nothing. I did not give you all that money to not be able to play your game, Dice/EA. Fix your shit.
SgtCooie
Enlisted: 2014-12-10
2015-02-09 00:15
Skyb0rg said:
I have fixed it by downloading
punkbuster http://www.evenbalance.com/index.php?page=pbsetup.php [evenbalance.com]

running pbsetup.exe
added the battlefied 4
and checked for updates.

now it works!!!

I think punkbuster just did not the update automatically.

Have fun.


Not a virus. I did this. Thanks man!
 
Thread is locked.
Thread is locked.