Thread is locked.

Uusupported 16-bit application

NL Enlisted: 2011-10-30
2013-10-11 20:53 , edited 2013-10-11 20:54 by PierrePonceur

I have an error when i'm trying to start de game:

Unsupported 16-bit application.

Full message there (even though I think it's useless): []

It was working fine, on the very first days of the beta (like 2nd or 3rd), I didn't play since then, just tried to today.

Windows 7 x64 (up to date)
HD Radeon 6800
SE Enlisted: 2011-10-25
2013-10-11 20:55
Try to repair or reinstall
Ignorance is a bliss for the ignorant ,but ignorance is a plague for everyone else.
NL Enlisted: 2011-10-30
2013-10-11 21:02
Well, this doesn't go well either:

Windows Programs panel, says it's already been uninstalled, and now it's not even in the list anymore.

I went to the install folder to check for a binary to repair/reinstall, only found one "cleanup.exe" and when I try to run it it's saying "A game file is corrupted. Please repair", that's ironic ^^

I can't see any way to reinstall from origin... any tips?
SE Enlisted: 2011-10-25
2013-10-12 13:04
Remove Battlefield 4 Beta folder in your Origin Games directory.
Try to clean the registry (ONLY THE REGISTRY) by using CCleaner (google it) or similar.
Maybe then you could do a fresh install.
Ignorance is a bliss for the ignorant ,but ignorance is a plague for everyone else.
Enlisted: 2011-11-22
2015-09-17 11:40
I have got the same error. I did start BF4 and did an update yesterday, now Hardline wont work.. Let me know how you go.
US Enlisted: 2011-10-26
2015-09-21 01:27
Same problem here. Does anybody have a fix?
AU Enlisted: 2012-07-12
2016-01-05 12:44
Go to your origin library right click bf4 and check for updates. It fixed mine, a lot easier fix than i thought. I haven't played in a while too because of it. Hope it helps you guys
Thread is locked.
Thread is locked.