possible sound loop crash fix-worked for me so far

user-four20
US Enlisted: 2011-10-28
2013-11-28 04:09 , edited 2013-11-28 04:32 by user-four20
I disabled the AMD audio drivers that I think were for the HDMI output. I am using an HDMI monitor, but not the audio. There were 6 in there, don't know why, but one was active. Right clicked and disabled it, played and got through 3 games with no crashes. Was crashing roughly every 3 games on average before this, sometimes multiple times per round (40 windows problem reports in ~55 hours). I also disabled the dolby audio on my audio device (Realtek, under the DTS tab). This may also be what worked.

start menu>control panel>hardware and sound>manage audio devices

Disable what you're not using to play and hopefully it works for you. I also disabled the dolby audio on my audio device (Realtek, under the DTS tab). This may also be what worked.

Seems to be working for me so far, will update if/when it locks up again.
troybob
US Enlisted: 2011-10-25
2013-11-28 04:11
This is my only real crash in BF. Disabling and will report back.

Thanks for the tip.
user-four20
US Enlisted: 2011-10-28
2013-11-28 04:12 , edited 2013-11-28 05:10 by user-four20
No prob, hopefully it works for ya. The sound loop seems to be my only issue too, other than a few texture glitches it's running great.

Update: just got through an 800 ticket locker round with no crash. Going to try shanghai.
Nasse83
FI Enlisted: 2011-10-27
2013-11-28 06:10 , edited 2013-11-28 06:10 by Nasse83
Its my only bug too. But it only happens on Shanghai, storm and dawn breaker. But it happens on those maps every time. Sometimes i can play a minute sometimes 10 but it will always crash on those maps.

Other maps i can play just fine.
FlyingJizz
CA Enlisted: 2013-10-29
2013-11-28 06:16
my only enabled audio device while playing is Siberia V2 USB headset so this doesn't work, and still crashes.
Frantic_Slug
US Enlisted: 2011-10-24
2013-11-28 06:17
Holy shit this worked! I was actually able to play a round on Shanghai. You're the best.
user-four20
US Enlisted: 2011-10-28
2013-11-28 06:18
Still working for me too. I've gotten through about 6-8 rounds with no sound loop crash.
ShadowF
US Enlisted: 2011-10-25
2013-11-28 19:00 , edited 2013-11-28 22:03 by ShadowF
Disabled everything not in use, will report afterwords. Thank you for the suggestion!!!

THANK YOU A LOT, FIXED THE SOUND LOOP!!!!!
user-four20
US Enlisted: 2011-10-28
2013-11-28 20:44
Anyone else have any luck with this? I got through a bunch of rounds last night with no crashes...
Ashratt
Enlisted: 2012-10-21
2013-11-28 21:20
i have not installed the audio drivers from the catalyst package but still get the audio freeze ups
user-four20
US Enlisted: 2011-10-28
2013-11-28 22:02
Is there anything in there other than the device that you use for the game? Try turning off anything else that's in there.
Pulldozer
NO Enlisted: 2012-03-17
2013-11-28 22:03
In addition, turning off hyperthreading might help.
"Time spent with cats is never wasted" - Sigmund Freud
ShadowF
US Enlisted: 2011-10-25
2013-11-28 22:03
Worked, THANK YOU!!!!
Lalilulelo1234
SE Enlisted: 2013-06-13
2013-11-28 22:08
IM gonna give this a try. Thnx for the tip.
user-four20
US Enlisted: 2011-10-28
2013-11-28 22:50
Nice! I just got through an 800 ticket round with no problems too on 311!
Pulldozer
NO Enlisted: 2012-03-17
2013-11-28 22:54
I posted this fix a month ago, but nobody listened.
"Time spent with cats is never wasted" - Sigmund Freud
Lalilulelo1234
SE Enlisted: 2013-06-13
2013-11-28 23:58
Nope it did not work for me. Siege crashed 2mins in as usual.
Hawxxeye
GR Enlisted: 2012-02-10
2013-11-29 12:04 , edited 2013-11-29 12:04 by Hawxxeye
sounds more like a placebo to me
We'll see
"People on the internet believe that in reality their opinion is fantastic! Its the best thing in the world! Its gold! You could sell it. You could eat for a year by selling just one of their fantastic opinions!" By TotalBiscuit
Starbusta
GB Enlisted: 2011-10-27
2013-11-29 12:15
user-four20 said:
I disabled the AMD audio drivers that I think were for the HDMI output. I am using an HDMI monitor, but not the audio. There were 6 in there, don't know why, but one was active. Right clicked and disabled it, played and got through 3 games with no crashes. Was crashing roughly every 3 games on average before this, sometimes multiple times per round (40 windows problem reports in ~55 hours). I also disabled the dolby audio on my audio device (Realtek, under the DTS tab). This may also be what worked.

start menu>control panel>hardware and sound>manage audio devices

Disable what you're not using to play and hopefully it works for you. I also disabled the dolby audio on my audio device (Realtek, under the DTS tab). This may also be what worked.

Seems to be working for me so far, will update if/when it locks up again.




this works for NVidia users too I did it 2 weeks ago not had sound loop since (still lose audio ingame sometimes so I guess the game still has problems)
Google is your friend
user-four20
US Enlisted: 2011-10-28
2013-11-29 18:23
Pulldozer said:
I posted this fix a month ago, but nobody listened.


I searched the forums, but never came across your post. Forum search sucks, but good call! Glad it's working for some, still haven't had a crash here.