Users on 32-bit operating systems have reported problems with installing the Battlelog web plugin and using Google Chrome. We're working to have this issue resolved before the end of the week. Affected users are encouraged to temporarily use another web browser.

I disconnect from the game every 20 minutes

Coordinator010
NZ Enlisted: 2011-10-26
2013-12-09 07:11 , edited 2013-12-09 08:57 by Coordinator010
I join a server and play as normal for 20 minutes with no problems, then my BF4 spontaneously pauses - everyone starts running in place for about 10 seconds, then I get a black screen and it kicks me out of the server with an error message about disconnection. There are no problems with my internet and I stay connected to all of my other programs including battlelog, but I can't play the game for more than 20 minutes at a time. Does this happen to anyone else?

ERROR
Game disconnected: client closed down connection.
Kelfaur
JE Enlisted: 2013-10-11
2013-12-09 08:47 , edited 2013-12-09 08:49 by Kelfaur
I've was having exactly the same issues since the latest client patch, the message was something along the lines of 'error: client closed connection'. I refused to believe it was my connection at first because I'd been playing fine before that. I'd been able to play between 10-20 mins then everything would freeze (people running on the spot) and I'd be kicked back to Battlelog. I checked my router which provides extremely vague logs, but noticed UPnP was dropping port mappings right before being disconnected from the game. Manually adding the port forwards on the router solved the problem for me. Try adding the following port forwards into your router and also make sure they're open on your client machine, in Windows Firewall or whatever you're using:

TCP: 80, 443, 9988, 20000-20100, 22990, 17502, 42127
UDP: 3659, 14000-14016, 22990-23006, 25200-25300

If you're unsure consult: http://www.portforward.com [portforward.com]
Coordinator010
NZ Enlisted: 2011-10-26
2013-12-09 09:08
Thanks for the advice, sounds like exactly what I'm encountering. Should I disable UPnP in addition to opening these, or is it fine as long as they're opened manually?
Kelfaur
JE Enlisted: 2013-10-11
2013-12-09 09:37 , edited 2013-12-09 09:46 by Kelfaur
You could try disabling UPnP now that you've manually forwarded the ports as it does present a security risk. I've since disabled UPnP on my router and had no issues.
Coordinator010
NZ Enlisted: 2011-10-26
2013-12-09 09:41
Holy shit it FUCKING WORKED! I JUST PLAYED MY FIRST ROUND OF BF4 WITHOUT CRASHING OR DISCONNECTING AAAAAAHHHH
I LOVE YOU BRO
Kelfaur
JE Enlisted: 2013-10-11
2013-12-09 09:47
No worries, glad it worked.
Medineuh
FR Enlisted: 2011-11-02
2014-01-08 04:06
This post has been removed by the Battlelog administrators.