Thread is locked.

No servers found, check filters and try again?

BananaGumBum
Enlisted: 2015-08-02
2016-02-02 17:49 , edited 2016-02-02 17:53 by BananaGumBum
I have been trying for 2 weeks, the server list does not show up in battlelog, only in the game. Every time i click multiplayer > server browser, it says "Sorry, no servers found. Please change your filters and try again.". I have heard that this is quite a common problem among Premium members, especially during these EXP boost events. I've changed every single filter and reset several times, nothing works.

What should I do? Are the game devs aware of this problem right now? I was looking over on previous threads about this, but no one ever had a solution. I know, "Why can't you just quit the internet and go play the game right now"? I created a battlelog account for a reason. A month ago everything was connected, back when i was on the 360. Any solutions? It's been 2 weeks and this error is still here. Is there a solution? Thanks.
Lemmywinks19
US Enlisted: 2011-10-25
2016-02-02 17:51
Just search with in game. I dont use battlelog simply cause I cant specify east or west US. Not interested in playing in west since I will be out of region.
CharlesSaint007
Enlisted: 2011-12-08
2016-02-16 15:52 , edited 2016-02-16 15:53 by CharlesSaint007
I have the same issue. No servers found for whatever combination of filters I use. I tried resetting the filters as well to no avail. "Just use the game" isn't really a valid reason for the website not working properly.
ChannonJ
Enlisted: 2011-11-04
2016-02-16 16:39
I'm not premium, but I can't remember the last time battlelog browser worked. Haven't used it since.
CyberDyme
MC Enlisted: 2014-05-18
2016-02-16 18:21
Frankiepies430 said:
I have been trying for 2 weeks, the server list does not show up in battlelog, only in the game. Every time i click multiplayer > server browser, it says "Sorry, no servers found. Please change your filters and try again.". I have heard that this is quite a common problem among Premium members, especially during these EXP boost events. I've changed every single filter and reset several times, nothing works.

What should I do? Are the game devs aware of this problem right now? I was looking over on previous threads about this, but no one ever had a solution. I know, "Why can't you just quit the internet and go play the game right now"? I created a battlelog account for a reason. A month ago everything was connected, back when i was on the 360. Any solutions? It's been 2 weeks and this error is still here. Is there a solution? Thanks.

I am willing to help you, if you have the patience to go through each setting one by one. This to make sure your filters are indeed not too tight, as that is why your search result list is empty. I have never had any problems with the server search function using the PC or iPad battlelog web apps. Commented previously also to others who indicated same problem as you note. And they all managed to get it to work afterwards, so lets keep fingers crossed that you also will succeed.

Hereby the first steps to try out:
1. Open your Multiplayer/Server Browser screen.
2. Click 'RESET'.
3. Now click on the magnifying glass, where it says 'SEARCH FOR SERVERS'.
4. Click to open/include also the advanced options, bottom left.
5. Now make sure all the square check-boxes are all empty!
6. Then tick the following:
a) FREE SLOTS (top middle), tick: NONE, 1-5, 6-10 and 10+.
b) TYPE (top right), tick: Official and Ranked.
7. Now you can press the button APPLY FILTER (bottom right).
8. You should now see a long list of servers that it found for you, fulfilling these filter conditions.
For me it found 168 servers (on PS4)...

Lets hear how it goes for you!?
Orchidiot
AU Enlisted: 2011-10-28
2016-02-21 11:40
The above didn't work for me on xbox one. Followed to the letter. I'm sick of wating for them to even acxknowledge that it's broken.
PeekATracked
Enlisted: 2012-03-09
2016-05-16 22:35
the above didn't work for me either, i can'y play online. Ive tried to connect trough battlelog.. then it says: the join game is running an incompatible version
When i try to find a server on ps4 its says: no servers found
when i try to find a quick match on either what mode it says: no servers where found.
Di5rupt1v31
Enlisted: 2014-04-22
2016-06-17 00:35 , edited 2016-06-17 00:35 by Di5rupt1v31
Started happening to me this afternoon. Tried everything and "no servers found". PC game
Shadders_X
GB Enlisted: 2012-10-15
2016-06-17 09:38
Hi,

Battlelog has worked perhaps upto 6 times since I purchased a PS4 in November 2013, so in essence, it has really never worked.

Regards,

Shadders_X.
 
Thread is locked.
Thread is locked.