Thread is locked.

Losing Key Packets 9003 punkbuster kick error

CaptainOrtaga
CA Enlisted: 2011-12-25
2012-01-03 06:46
I cannot play Battlefield 3 anymore due to this error. I can join servers, but anywhere within 2 to 5 minutes I am kicked for a "losing key packets 9003" error by punkbuster.

This is very clearly a problem with punkbuster, or its compatibility with the game: i ran a command prompt test and got 0% packet loss. You can also find similar complaints of the same glitch with punkbuster in previous battlefield games from a simple google search.

It had a sudden onset after 30 hours of mostly glitch-free gameplay (which included being forced to drop from games due to - and occasionally TK the hell out of - cheaters. one wonders how effective punkbuster even is?). I have reinstalled battlefield 3, reinstalled punkbuster, updated punkbuster, rebooted, etc. etc. etc. with zero results.

Is there any fix for this? Is anyone at DICE/EA/punkbuster working to fix it or should i be returning battlefield 3 to the store and getting my money back?
Dezezez
Enlisted: 2011-10-30
2012-01-05 05:33
Same problem, done absolutely everything to try and fix it and it still doesnt work.

No sign of any fix on EA site, either.

Communication from the developers/producer, and even PunkBuster, is sh1thouse.
Ghensler
Enlisted: 2011-11-29
2012-01-08 19:07
Same problem here.
CourtesyFart
US Enlisted: 2011-11-12
2012-01-08 19:10
This used to happen to me in BF2 from time to time. Reinstalling the game was always the fastest fix.
Bazilisk2
CZ Enlisted: 2011-12-24
2012-01-08 20:22
Hi,
Happened to me too just now. Last played some 5 hours ago. When I tried running it again two hours ago it has stopped working. I can connect to the server, but I cannot deploy or join squad. But I can watch the game on the background of the menu, can browse leader boards etc.

Here's what I did so far:

Tried disabling firewall & antivirus.
Tried reinstalling firewall & antivirus to another brand (from Norton to NOD32).
Tried disabling firewal & antivirus again.
Tried smashing keyboard randomly and rain dancing.

Nothing worked.

On side note, my new NOD32 firewall keeps popping up with error on server browser refresh, (not in the game):
"Detected covert channel exploit in ICMP packet"
But I don't think it's related.

I'll give it till tomorrow then contact tech support.
Hav0k66
Enlisted: 2011-10-26
2012-01-09 01:52
I'm also getting this problem frequently. Definitely pissing me off. I paid $60 for this!?
Ghensler
Enlisted: 2011-11-29
2012-01-09 23:50
It's getting more common for me. Before, it would happen to me in a handful of rounds, but now it happens in almost every round I play. I've found "solutions" in other forum threads, but none of them have worked.
DA-VOID1
US Enlisted: 2011-10-25
2012-01-10 04:11 , edited 2012-01-10 04:11 by DA-VOID1
Bunch of BS..been getting it more and more.
Rum-Rebellion
AU Enlisted: 2011-10-29
2012-01-10 09:43
I have the same problems. I got hold of evenbalance (punkbuster) and they worked me through a few solutions which have NOT worked.

This is becoming a serious problem and needs review.

EA obviously don't care because they don't comment or even read these.

Next time put the title in ALL CAPS - that will get there attention!!!
oMazo
Enlisted: 2011-10-25
2012-01-10 22:13
Sad too see developers not take care of their games like they should..... and they wonder why they are losing to activision..
Zcoot
AU Enlisted: 2011-10-26
2012-01-11 01:55
Look the amount of errors and problems users of the battlefield series have had with punkbusters is not that funny anymore. I got bored of it after 2142.

This might be a slightly better idea but if they did a steam release and use VAC, I rearly see a hacker and if so I normally see him banned on the spot.

Although this is just my opinion
sekasi
AU Enlisted: 2011-11-01
2012-01-11 02:08
I don't know why this worked (I really don't), but it did.

I had this problem for a few days, came out of nowhere, and happened in EVERY GAME.

Saw some dude saying "hey turn off your router for 5-10 minutes, LEAVE IT OFF! And then restart it" .. and the tech part of my brain went 'why the hell would that do anything", but I was desperate, so I tried.

Lo and behold, it went away. Never had it since.

Shrug.

Wizards.
ALMOSTYETI
ZA Enlisted: 2012-01-07
2012-01-11 14:52
Very dissapointed, this is the first BF game ive played i used to only play COD, up to the point that athe game crashes with a punk buster error its the best fps ive played, but the game never finishes and always crashes with the packet loss error
OhMy_DrDeath
IM Enlisted: 2011-10-25
2012-01-11 17:44
I had this loosing key packets issue. It started anew after weeks of no problems. Updating my ATI video driver to latest fixed it. (a fix I found on google and worked for others too). I have no idea why PB would be affected by video drivers but there you go. Might be worth a try for those of you with ATI cards. Might even work with nvidia cards too.
http://battlelog.battlefield.com/bf4/servers/show/pc/64fd6612-5757-4c13-b81c-83dc6bde3e3f/Oh-My-Guts-TDM-400-tickets-64p-No-Rules/
BlakkheimGW
FR Enlisted: 2011-11-04
2012-01-12 18:28
Same here. It used to appear in almost every game I was playing when I was connected via WiFi to my router (whereas the connection was very stable and error-free when playing no PB polluted games). When I confirmed this issue, I tried to use an ethernet cable : the problem totally disappeared during few weeks. But since a week, it is back to business. Every two or three games, I got disconnected with this error. I've tried every solution posted on the web with no result.

As everyone said, the problem is still here since ages and since the beginning of BF series w/ PB. It's a shame. PB is a shame.
Simello
IT Enlisted: 2011-10-28
2012-01-16 22:09
Same here, i tried the same things Bazilisk2 did, rain dancing too, but nothing.
DecapitatedHorse
AU Enlisted: 2011-10-27
2012-01-17 07:28
download pb setup, start it before playing... worked for me
Premiumfield 3
redhotswitch
Enlisted: 2011-12-02
2012-01-26 12:09
restarted router
updated ATI drivers
left punkbuster setup running
....
still got the Losing Key Packets 9003 error...
Kimchi_adnia
KR Enlisted: 2012-01-11
2012-01-26 13:21
same here... wtf!!!!
OMeN_CT
ZA Enlisted: 2012-01-09
2012-01-26 17:53
Got to say, I hate this.... This game has given me more problems than any before. Its a nice game , but OMG its just one big problem. Im going to talk again to tech ,for the last time, and if I cant get this sorted out I am going to take the game and burn it. Ive spent like 14 hours playing the game. Ive spent 10 hours trouble shooting online, 2 hours on skype with tech and 1 hour on the phone with tech. So after this call my troubleshooting = game time.

EA, I play games to relax, this game has been the most unrelaxing game to try and play in my life. I now have a grudge against EA for screwing around with my relax time. 4 fatal problems so far "4"....fatal......

Im going to go buy COD....
 
Thread is locked.
Thread is locked.