Thread is locked.

Direct X Error

VulcanbomberUK
GB Enlisted: 2012-11-09
2012-12-24 02:03
Well things start working and now they are not.......

So I start multiplayer and now this happens you get the bong in the back ground and i have a black screen to look at with this error.....

Direct X function "DX Renderer:map Failed" with E_Out of memory; ran out of memory GPU "AMD Radeon HD7800 Series" Drive 12.10 (9.002-120928m_149042C-ATI) free vert mem 2759624kb/4194176kb total sourse mem 0kb make sure you have a supported graphics card with at least 512MB

Now can some one please explain this to me as this is a brand new graphics card and it has 2 GB of memory this is pulling my hair out.....
1Table1Wasabi
CA Enlisted: 2011-10-25
2012-12-24 02:07
re install directx from microsoft and the graphic card driver
VulcanbomberUK
GB Enlisted: 2012-11-09
2012-12-24 02:22
I have no idea which one from microsoft ? there are some many of the dam things!!!!
1Table1Wasabi
CA Enlisted: 2011-10-25
2012-12-24 02:24 , edited 2012-12-24 02:26 by 1Table1Wasabi
http://www.microsoft.com/en-us/download/details.aspx?id=35 [microsoft.com]
VulcanbomberUK
GB Enlisted: 2012-11-09
2012-12-24 03:42
Thanks for that but still no luck so have I got to uninstall the graphics driver and then reinstall?
KeepTheChangeKid
US Enlisted: 2012-03-13
2012-12-24 10:46
BomberNZ said:
Well things start working and now they are not.......

So I start multiplayer and now this happens you get the bong in the back ground and i have a black screen to look at with this error.....

Direct X function "DX Renderer:map Failed" with E_Out of memory; ran out of memory GPU "AMD Radeon HD7800 Series" Drive 12.10 (9.002-120928m_149042C-ATI) free vert mem 2759624kb/4194176kb total sourse mem 0kb make sure you have a supported graphics card with at least 512MB

Now can some one please explain this to me as this is a brand new graphics card and it has 2 GB of memory this is pulling my hair out.....

if the message is correct, it may require you to upgrade your video card. I would suggest a card with minimum 1 gb onboard memory. If that's not the case reinstall your ATI drivers with the latest beta driver.
VulcanbomberUK
GB Enlisted: 2012-11-09
2012-12-24 22:31
LOL funny thing is its a HD 7850 with 2 GB GDDR5 OC I bought it for this game.

I have now turned all the video settings to low to get it to work, I have found a load of drivers on the sapphire web site to load up which I will try later. but hey ho here we go. merry christmas every one....
zero_cache
CY Enlisted: 2011-10-29
2012-12-24 22:48 , edited 2012-12-24 22:48 by zero_cache
Did you use driversweeper after the driver uninstall? If not - do so. ATI drivers tend to have a messy uninstall at times. Once done install the latest drivers from ATI. If you still get a memory issue try the card on another machine if you can. If it fails there then send it back from where you got it and get a replacement. The memory could be faulty.
VulcanbomberUK
GB Enlisted: 2012-11-09
2012-12-24 23:57
Cheers for that having a look at the driver sweep programs you can get looks to be a couple that people use a lot so will give it a go.
ShavedAp3
GB Enlisted: 2011-10-24
2012-12-25 00:00
I tend to use ccleaner but get the same results there is also a microsoft one installer database or something along those lines.

When installing ATI drivers its always worth cleaning as you go once I got into that habit I have never had issues with ati drivers ever.
VulcanbomberUK
GB Enlisted: 2012-11-09
2012-12-27 23:32
Well after all that and more, i can now only play the combat games?????? everything else, home run teamdeath match and the such like all fault out with the same error. Now I am at a total loss as what to do. oh Happy new year....
RosieRascal
CA Enlisted: 2011-10-30
2012-12-28 00:31
As oithers have said, make sure you are running the most up to date ATI beta drivers for your card as a lot of radeon video card owners had issues and this is a common error that was out there before the new beta driver came out. Remove the old drivers and do a clean install of the new ones.

Also make sure your sound drivers and other hardware drivers are up to date as they could also be causing this (particularly if you are getting noise feedback when it crashes).

Once all of your drivers are up to date, if you still have issues, it may be something as simple as your anti-virus program corrupted the install of directx from the mohw install and you need to reinstall it.

If you are running this through steam the dxsetup can likely be found here:
Program Files or Program Files <x86>\Steam\Steamapps\Common\medal of honor\install\DirectX\DXSETUP.exe

If you are running this through origin, it should be here
Program Files or Program Files <x86>\Origin Games\Medal of Honor Warfighter\_Installer\directx\redist\DXSETUP.exe

If everything is updated and the dxsetup install run and you still have issues, try right clicking on the mohw application from windows and selecting Run as Administrator to see if that solves the problem.
nrkRISE
FR Enlisted: 2011-10-26
2012-12-28 00:40
bump
VulcanbomberUK
GB Enlisted: 2012-11-09
2012-12-28 04:05
Cheers Dog Pound I will give it a go.
FRS_Anthony
US Enlisted: 2012-11-23
2012-12-28 04:16
Having the same problem, I have a GTX 660.
RosieRascal
CA Enlisted: 2011-10-30
2012-12-28 11:45
Same would apply to Nvidia, driver version 310.70 appears to solve their game crashes but will not solve the directx error for you. Try what I suggested above, Durdinn.
NITRAsvk
SK Enlisted: 2011-10-28
2012-12-28 21:19
and i buy new Sapphire 7950 with BOOST and i got this one :

http://i46.tinypic.com/20f6s12.png [i46.tinypic.com]

any idea?

game stopped everytime after intro logos animation ....

latest soft ....
Kismodrx04
NL Enlisted: 2011-10-27
2012-12-28 22:49
same problem. Radeon 7870 with 2 gig. No one has any answer. Perhaps it's the cpu? I do have a core2 e8400?

Think it;s a game problem. All drivers up to date, direct x reinstall, latestt beta drivers etc. etc. Still a problem, and only sector control.
FRS_Anthony
US Enlisted: 2012-11-23
2012-12-29 06:02
I've tried everything still no luck.
VulcanbomberUK
GB Enlisted: 2012-11-09
2012-12-29 08:36 , edited 2012-12-29 10:22 by VulcanbomberUK
Well I have put the latest Beta driver in and will soon see was able to play a couple of rounds last night with no problems when running in administrator so will see tonight.......(update) so now have updated with latest Beta from Sapphire and run in admin and have played a couple or rounds of team death match and hotspot and combat looking ok for the mo, thanks to everybody how helped out with it all....
 
Thread is locked.
Thread is locked.