Battlefield 4 Crash on Deploy

Rayesmiza
CA Enlisted: 2011-10-25
2013-10-29 07:44
OK so i pre-ordered the game worked fine for first hour or so but then after a while i started playing and when i would die and try to re-deploy on a squad member or at alpha or something it would just crash (BF4 has stopped working) have to start task manager to close it, its random when the crash will happens sometimes its early in a game sometimes its later in a game I have the latest driver version and checked other posts nothing about this one so far so if someone could help that would be great.

The Game also cant send error report or anything because it says the game has stopped working and waits for me to force close it.

Also adding that I did not have this problem during the BF4 Beta, I also tried putting it to windowed mode but that also didn't work I am also using google crome but I dont think that's what causing it
HarrystheName
Enlisted: 2013-05-24
2013-10-29 08:43
same thing is happening to me
ZILZAL_MIX
Enlisted: 2012-03-17
2013-10-29 12:49
here also crashes , in SinglePlayer and Multiplayer ,
grimmerss
Enlisted: 2011-10-26
2013-10-29 12:51
happen to me also
Rikuti
FI Enlisted: 2011-10-24
2013-10-29 12:54
yep same here! or after few minutes of play.

System specks :

Intel 3570K
GTX 780
16 gigs ram
Windows 7
Drivers 331.40

Cant play whit newer ones because of color errors.
Zeleby
Enlisted: 2013-10-13
2013-10-29 16:15
3rd time crashing, i dont know what to do...
Danyu1d
CA Enlisted: 2011-10-25
2013-10-29 16:30
mine essentially only crashes if im respawning and the screen goes black before redeploy.... thats the point it sometimes crashes.
kze86
CA Enlisted: 2011-11-29
2013-10-29 16:37
Platform:
PC 64-bit

PC SPECS:
i7-3770k
GTX 670 (driver 331.65)
16gb ram
Windows 7 64-bit

Here's how it happens, when I die, I click on squad member, click on deploy... sometimes the screen will stay black and the game will crash to desktop saying "Battlefield 4 has stopped working". It's ruining my experience... it happens on EVERY game session... happens after a minute, 5 minutes, 10 minutes or even on the first deploy sometimes.

I thought maybe Punkbuster was the issue but it also happens on servers where Punkbuster is Disabled. I ran a manual update using pbsetup.exe and the problem still occurs.

Can you confirm if someone will look into this? I pre-ordered and paid 50 extra dollars for premium... I used a 50% xp boost and I can't fully enjoy it (unable to finish a game) .... I have ~75% quit ratio on my profile because of this bug.
ray11023
Enlisted: 2013-10-29
2013-10-29 16:37
getting the same thing.
Politikill86
US Enlisted: 2011-10-25
2013-10-29 17:03
Yeah the game has crashed on me three times today, got a blue screen too. My machine is brand new too.
kze86
CA Enlisted: 2011-11-29
2013-10-29 17:04
Does it crash when you hit on deploy? That's why this thread exists.
poshbagel
US Enlisted: 2011-11-01
2013-10-29 17:08
same here guys been trying playing. Crashed 10 times sigh...
Politikill86
US Enlisted: 2011-10-25
2013-10-29 17:08
Yes and Yes. Regardless of where it happens, the game still has bugs that causes crashing...
Zeleby
Enlisted: 2013-10-13
2013-10-29 17:09
yeah, at least for me, after the 4 deploy i crash
bodeen87
US Enlisted: 2013-10-03
2013-10-29 17:13
same shit for me
xCRIMSONxGUARDx
US Enlisted: 2011-10-25
2013-10-29 17:27
i have crashed on 7 of the 8 games i played, running gtx 650 ti with newest driver and it crashes on single player also, i really don't know what to do. already did the repair install so any more suggestions would be nice.
Reign5upreme
US Enlisted: 2013-10-01
2013-10-29 18:00
The game crashes before I can even get in. Both campaign and multiplayer.
kze86
CA Enlisted: 2011-11-29
2013-10-29 19:07
Bump
Rayesmiza
CA Enlisted: 2011-10-25
2013-10-29 20:05
bump
bodeen87
US Enlisted: 2013-10-03
2013-10-29 20:52
its really nice that we cant get any feedback on this topic