BF4 will not load past the rainy scene page

cqdx-1
NZ Enlisted: 2013-04-10
2014-02-03 05:42
RiEvEr_EU, you beauty! That was it. I have 3 controllers and "my" one was assigned as controller position 4. When I re-assigned it to 1 - bingo no more sitting in the rain...

Battlefreezers unite, as it looks like we have a workaround. Thanks to everyone who contributed, it was nice to know that I was not alone.

Hope this works for all of you until the next patch! LOL

Eyes on the target guys!
Kris4Fizz
AE Enlisted: 2012-06-15
2014-02-04 14:16
Just to reinforce this work around, I too have a Gran Turismo 6 Logitech Wheel attached to my PS3, and by default it holds controller assignment 1. Unplug it, let the PS3 controller have the assignment one and no more rainy screen.... No idea why that works, but it does!

Game on!!
reefermaaanz
CA Enlisted: 2011-10-26
2014-02-04 15:27
I hope someone relates this glitch/bug to Dice/EA so they can fix it, this happened to me also, and i was charging the <1> and without thinking turned on another one to try and use it but kept getting the raining screen, but if this is the problem then i would gues re-assigning the controller <2> to <1> would have fixed it.

Something constructive has come from the Battlelog.

BUMP DICE!!!!
Gladiator341
Enlisted: 2011-12-26
2014-02-06 19:01
I was having the same problem today. It was freezing on the rainy city scene. The controller I was using was set at controller (2). I changed it to controller (1) then exited the game and went back in using this controller as (1). Boom worked just fine. Anyone being stuck on the rain scene make sure you enter the game from the beginning with a controller assigned as (1).
u0681887
US Enlisted: 2011-12-04
2014-02-16 01:22
FIXED!!!! Problem Solved!

YOU NEED TO MAKE SURE TO "REASSIGN CONTROLLER TO 1" I've been playing GT6 and leaving my Driving Force Racing Wheel connected. I disconnected my Driving Force Racing Wheel from the USB port and did a hard shut down-reboot and I've past the raining city - FINALLY!

MAKE SURE YOUR CONTROLLER IS SET TO "1"

I hope this works for you guys!
bioniclepear2012
GB Enlisted: 2012-01-03
2014-03-01 15:05
worked for me cheers dude
thephysicsofwar
Enlisted: 2014-01-05
2014-03-27 19:32
same here but when i try i just reload the page but cannot select servers to play on :/ like if i click the arrow to play nothing happens any advice anyone?
grafniko
US Enlisted: 2012-01-22
2014-03-27 19:34
Restart the game. Happens to me sometimes when I switch from a different game to BF4.