AMD Catalyst 14.1 Download ("Mantle Driver")

cuetime
AU Enlisted: 2011-10-26
2014-02-04 06:41
Mehisx said:
I have tried everything for uninstalling, ddu, ccleaner, nothing helps i insatll 14.1 but it still shows 13.12 ??? I have msi gx70 laptop 8970m


run driver fusion after your uninstall the driver to get rid of the reg entries left behind, restart and re install. Driver fusion will tell you it couldn't remove all files without upgrading to premium, ignore that BS it gets rid of them with the free version.
Yapo1201
DE Enlisted: 2014-01-04
2014-02-04 09:21
Mehisx sagte:
I have tried everything for uninstalling, ddu, ccleaner, nothing helps i insatll 14.1 but it still shows 13.12 ??? I have msi gx70 laptop 8970m


I've got the same laptop!! The current Driver is not optimized for 14.1, so you won't have the option in BF4 for using mantle
When i installed the driver it also showed 13.12 to me, but its just a bug! If you look at the Driver Version, not the Catalyst Version you can see, that its the 14.1 driver.. only the 13.12 number is shown wrong..
If you want to use Mantle with 8970m - There is a moded Version of the driver, that supports some mobility Graphic Cards .. just search for "Catalyst 14.1 moded" :)
But for me it doesnt work, becaus BF4 Crashes directly after start :)
Hope i could help :)
BadNFunkedUp
GB Enlisted: 2011-11-02
2014-02-04 09:35
Didn't bother with any fancy uninstalls as suggested but installed 14.1 with no issues. My i7 4770k & R9 280x setup is useless with mantle, hugely inconsistent frame rates. Would suggest that not only is it not optimised for 280x yet as stated, but it's useless. Advise anyone with a similar setup to stick to DX11 & 13.12 drivers for now till next release and save yourself the headache.
confiscate
Enlisted: 2011-11-02
2014-02-04 10:06
Yapo1201 said:
When i installed the driver it also showed 13.12 to me, but its just a bug! If you look at the Driver Version, not the Catalyst Version you can see, that its the 14.1 driver.. only the 13.12 number is shown wrong..


Thank you! I have the same laptop and the same problem, instaling 14.1 shows 13.12, but I'm glad to hear it's apparently just a bug! I would have kept reinstalling without getting anywhere.

But how do we know what driver version it is from the Driver Packaging Version code? In other words, how do we know what 13.35.1005-140131a-167668E-ATI equates to? Is there a reference somewhere that says that code equals 14.1?

Also, for my brother on a desktop it properly shows 14.1, but his Packaging Version Number is 13.35.1005-140131a-167669E-ATI (9E instead of 8E). Is that just because his is the desktop version or something?
XxHang_TuahxX
MY Enlisted: 2011-11-05
2014-02-04 10:40
Mehisx said:
I have tried everything for uninstalling, ddu, ccleaner, nothing helps i insatll 14.1 but it still shows 13.12 ??? I have msi gx70 laptop 8970m


same lol... im on gx60
halninekay
DE Enlisted: 2011-10-27
2014-02-04 11:35
I can't get the game to work now. yesterday I played fine. R9 290X. Now the game crashes with white screens etc.
Passionate Purgatorial Janitor since BF-1942 | DICE Friend | Battlelog Moderator | Maintaining the Battlefield's purity!
Yapo1201
DE Enlisted: 2014-01-04
2014-02-04 12:29
confiscate sagte:
But how do we know what driver version it is from the Driver Packaging Version code? In other words, how do we know what 13.35.1005-140131a-167668E-ATI equates to? Is there a reference somewhere that says that code equals 14.1?



I saw some Screenshots, where the driver version was shown so i noticed that only the catalyst number is wrong. Im not sure about your brother, but the Desktop Driver could have a different number. 13.35 is the current Driver and 14.1 the catalyst number so i think if theres a 13.35 at the beginning its the new driver. But as i said, even if you install it now, you cannot enable Mantle in Bf4 :/ I think we have to wait for future Drivers for our Laptops to work fine :(
lorddigital
Enlisted: 2014-01-05
2014-02-04 12:37
My game just keep on crashing and automatically restarting from the last checkpoint again and again. This is after downloading the new 14.1 drivers and enabling mantle. I have r9 290 and i5 4670k. Does anyone is having the same issue.? Please any input will be appreciated. This new mantle thing just screwed up my whole battlefield game.
Red_Cliff_II
CH Enlisted: 2011-11-13
2014-02-04 13:00 , edited 2014-02-04 13:02 by Red_Cliff_II
so this means i cant play bf4 becouse i cant get amd catalyst 13.12 or higher becouse im on amd radeon hd 4400 driver!?!?! (latest 13.9) -.-
when i bought the game it said min. req. amd radeon hd 3800 wtf.. so i have to buy a fking new driver to play it or is there a other way?
from-hell-1977
Enlisted: 2011-10-28
2014-02-04 13:03
I have small lags with 14.1 i think ...
CarlosHathcock25
HR Enlisted: 2011-11-30
2014-02-04 13:24
I've tried using 14,1 beta drivers (with Mantle) on my R9 270x and it still needs more polishing... its either smooth like glass or it lags like no lag you've seen before...

So I've decided I'm going back to 13.12 driver until they get the shit done properly!
KING5TON
GB Enlisted: 2011-10-27
2014-02-04 14:10
TTsamoTT said:
i have an ocd 7850 + i5 3570k and with mantle i get lots of stuttering and very rarely extra fps. my gpu crashed once too while using it. however the 14.1 patch brought noticeable improvements to D3D. i'm getting min 60 even on shanghai in the open areas. settings are ultra, with the exception of lighting and effects which i have on medium and high, and the AA which i keep turned off. i have vsync off, but i'm running the game in borderless window so it doesn't matter. i fail to see the improvement, although many people consider my CPU to be pretty bad


Your CPU isn't bad, it's a good CPU (I've got one) and will not be holding back a 7850.

The reason you aren't seeing much of an improvement is two fold
1 - Mantle is not as yet optimized for your GPU, it will in time.
2 - You're not being CPU limited so you're not gaining as much as someone would who was CPU limited
GIGABYTE WindForce Radeon HD 7970 OC'd to 1Ghz, i5-3570K OC to 4.4Ghz, GIGABYTE GA-Z77X-D3H Motherboard, 8GB (2x4GB) G.SKILL RipjawsX 1600MHz CL9 DDR3, 750W Cooler Master GX750 80PLUS Bronze PSU, 1TB Seagate Barracuda SATA III Hard Drive, 120GB + 240GB Samsung SSDs, K750 solar powered keyboard, G700 wireless gaming mouse, Fractal Design Define R4 Black Case, DGM IPS-2701WPH 27" 1440p Monitor, Corsair Vengeance a1500 7.1 headset, Windows 8.1
PlunderFlaps
Enlisted: 2011-10-28
2014-02-04 15:30
totally unstable and not worth using on the r9 290x with the amd FX 8350 processor. Why they released this is completely beyond explanation. it caused the memory on the card to max out/leak .

I can confirm that the difference in FPS is absolutely mind-blowing but once i install the drivers and play one round, the game crashes my PC after that until i remove the driver and reinstall.
Xxelaa83
Enlisted: 2013-10-04
2014-02-04 15:38
TOMOTRONIC said:
i was getting an average of 100FPS on all maps yesterday with mantle today im getting 42 WTF

R9 290x
i7

anyone else getting this shit ?


Same happens to me on my 290 / fx 6300 system and the only ”fix ” is to give a restart after I turn on the pc. Try this, see if it helps
PlunderFlaps
Enlisted: 2011-10-28
2014-02-04 15:53
Fanboiscry said:
TOMOTRONIC said:
i was getting an average of 100FPS on all maps yesterday with mantle today im getting 42 WTF

R9 290x
i7

anyone else getting this shit ?
Mantle will never work well for you.
Unless you get crossfire, your cpu is powerful enough to where you will have 0 benefit with mantle


"Mantle will never work well for you" - Do not acknowledge this comment, because it is utter garbage.

I for one experience a huge improvement. I use maxed out settings and I do not drop below 60fps (monitor runs at 60hz). It runs perfect, however there is a huge issue with the patch. After playing the game once using mantle, it begins tom freeze on load-up on most maps and requires a restart (windows), then the only thing that will allow me to play again is by uninstalling 14.1 then reinstalling it. Bummer.
gtrsavas
Enlisted: 2013-02-21
2014-02-04 21:21 , edited 2014-02-04 23:25 by gtrsavas
DerKeysersoze said:
gtrsavas said:
DerKeysersoze said:
Yapo1201 said:
mazzachief sagte:
get a display driver uninstaller first ddu, from guru 3d
then it will install properly
Thats what i did! .. the whole day i tried different Cleaner also in Safe mode etc... but it always shows 13.12.. but now i noticed that the Driver version is correct, so i just need to change the Catalyst Version.. does somebody know how to do that? :) thanks!
Are you on a mobile Radeon?
DerKeysersoze,
I have the same problem as Yapo1201. And I'm on a mobile Radeon. Alienware mx17 w/ 7970m. I can't seem to get my AMD Catalyst Control Center version to 14.1, it always shows, 13.12.. But the driver version is 13.35.1005-140131a-167668E-ATI.
My previous driver version was 13.11. I uninstalled using AMD cleanup util 1.2.1.0.
Restarted, checked that no amd/ati under programs menu to uninstall. I installed amd_catalyst_14.1_mobility_betav1.6.exe.
Can't see API or mantle under video options in the game. Can someone help me?
I'm having the same issue but with a 8750m so it could be related to mobile GPUs not supporting mantle yet maybe? i'll keep trying and report back.


**Update Apparently M- GPUs are not supporting mantle yet so i guess that's why it doesn't work :/


**Update #2 :) http://leekms.blogspot.com/ [leekms.blogspot.com] this dude got it working. enjoy.


It worked !!!.
Thanks a lot for the link. Both Star Swarm and BF4 shows Mantle options and work without problem. Also Catalyst shows the correct version as 14.1.
BF4 gives about %30 more fps. Only problem is, sudden fps drops in BF4.

*Update, I get the same fps on Test Range, whether it is Mantle or DX, I"m gonna test Multiplayer furthermore.
lorddigital
Enlisted: 2014-01-05
2014-02-04 21:44
Xxelaa83 said:
TOMOTRONIC said:
i was getting an average of 100FPS on all maps yesterday with mantle today im getting 42 WTF

R9 290x
i7

anyone else getting this shit ?
Same happens to me on my 290 / fx 6300 system and the only ”fix ” is to give a restart after I turn on the pc. Try this, see if it helps


My game just keep on crashing and automatically restarting from the last checkpoint again and again. This is after downloading the new 14.1 drivers and enabling mantle. I have r9 290 and i5 4670k. Does anyone is having the same issue.? Please any input will be appreciated. This new mantle thing just screwed up my whole battlefield game.
BustdaRPG
GB Enlisted: 2012-11-02
2014-02-04 23:38
So have AMD got a date set for the full 14. drivers as compared to the 14.1 'beta' drivers?? Or do they just release them when they feel like it??
PlunderFlaps
Enlisted: 2011-10-28
2014-02-05 00:13
I have found a fix for the crashing on the R9 290x!!!!!!! (well one of a few things fixed it but I'm sure of which one did it!!!! in windows goto your RUN box and type 'msconfig' and click on the start up tap. Look for the catalyst control centre and UNCHECK that box. you don't want that loading up on boot. run the game.

Please let me know how that fairs, and if it didn't work, its' likely to be one of the hardware managers that you have installed, because the other things I deselected for bootup was anything to do with the motherboard software (i use the m5a9xx EVO R.2.0 and there were a few monitors installed with this)

Really hope this helps someone because it has been my absolute bain since i installed 14.1 and used mantle.

I have done a few things to get it to crash so that I didn't waste your time such as - ran every map, tabbed out of game and ran hardware monitors, used my browser etc. nothing has caused the game to crash since I carried out the *above* steps.

So pleased :D bf4 runs so nice now lol

(btw if you're using an intel processor, disable the on board gpu)
FlintLock_NL
NL Enlisted: 2011-10-27
2014-02-05 00:18
Game now crashes all the time with the new beta drivers Ati Catalyst 14.1 !!!
BF4 is become very unstable! It's even unplayable for me ATM :(

I am going back to 13.12!