Thread is locked.

BF4 PC Issues reproduction & information

t1gge
US Enlisted: 2011-10-25
2014-07-30 04:23
Hi guys,

As we are trying to reproduce the issues some of you are having, we need to get more details - hence this thread. If you have PC specific issues with:

- General performance (that degrades and eventually fails)
- CPU stutters
- Crashes

Please post in this thread. Include as MUCH information as you can, and if you know of a way to trigger the issue, include that too (the more reproducable/clues the better).

We're looking for details like:
Windows version, Driver versions, Direct-X dumps, Settings files, Origin version, web browser etc.

We need to know:
What server, Map, When issues started (do they start during the same part of a game?), as much details as you can think of.

We also need to know:
What you have tried - did you reinstall the game, change drivers, tweak settings, or if you are running some special user.cfg file.

If you have HAD issues - but they are currently improved or GONE, please post here as well so we can gather more information about what could be helping people.

Please utilize the Performance monitor if you include videos etc, it helps alot!

Thank you, and lets get to the bottom of this.
Thwizzle-X-Shoot
Enlisted: 2012-08-31
2014-07-30 08:29
Great thread. I still think a lot of people are having crashes and FPS issues. Luckily, I have made two videos which apparently fixed these issues for thousands of people. I'm not saying that it will fix everything for everyone, but so far I believe these videos are pretty popular in the genre and I have gotten many friendly comments and likes for helping them. Besides, if you are still crashing after all this time, it's worth a shot right?

Here are the videos:
- How to Fix Battlefield 4 from crashing: https://www.youtube.com/watch?v=F8Mdfe9r3bQ [youtube.com]
- How to increase FPS in Battlefield 4: https://www.youtube.com/watch?v=F8Mdfe9r3bQ [youtube.com]

I even helped xFactorGaming out and he gave me a nice comment on one of these videos!

ps. Haters are welcome too, they just don't get any attention.
Why act serious in a crazy world?
lordCriper
CH Enlisted: 2011-11-05
2014-07-30 08:30
Not sure if this belongs here, but here goes.

Played BF4 last week without issues, steady FPS at High/Ultra settings. Went away for a week and wanted to play yesterday. Started up a multiplayer game and this is what I experienced:

- Game is very slow to load
- When it is loaded the textures seems to be of low quality
- There is massive lag and tearing

At first I thought there was a problem with my Nvidia Geforce GTX680. It's a Gainward Phantom 4GB card. However, I started up Farcry 3 on Ultra and it runs smooth. I also tried CoD Blackops, same story, it runs great, hate the game though ;-)

Then I saw what the problem was, Battlefield just refuses to utilize my Nvidia card, it seems to be fixed on running on the integrated Intel HD GPU all of a sudden. As I said I was away for a week, my PC have been off and nothing have been installed or removed.

I have tried with 3-4 different Nvidia drivers and the problem stays the same. Yes, I completely remove the drivers before installing the new ones. I've done the same with the Intel HD graphics drivers and sound drivers.

I simply cannot get the game to use my Nvidia card. I've monitored the GPU activity (MSI Afterburner) and the GPU load is next none on the card.

Any help would be appreciated!

CPU: Intel i7 2600K @ stock
MB: ASRock Z68 Extreme 4
GPU: Gainward GTX 680 Phantom 4GB, NVidia
RAM: Corsair Vengeance 2x8 GB

All games runs perfect, except Battlefield 4. It did a week ago though...
Simmo2302
AU Enlisted: 2011-12-21
2014-07-30 09:29
t1gge said:
We're looking for details like:
Windows version, Driver versions, Direct-X dumps, Settings files, Origin version, web browser etc.

We need to know:
What server, Map, When issues started (do they start during the same part of a game?), as much details as you can think of.

We also need to know:
What you have tried - did you reinstall the game, change drivers, tweak settings, or if you are running some special user.cfg file.

If you have HAD issues - but they are currently improved or GONE, please post here as well so we can gather more information about what could be helping people.

Please utilize the Performance monitor if you include videos etc, it helps alot!

Thank you, and lets get to the bottom of this.


Mobo: Asrock 890GM Pro3 R2.0 - lastest bios & drivers
CPU: AMD Phenom II x6 1090T @ 4.0Ghz - W/C
Multi - x20
FSB - 200
Volt - 1.45
CPU-NB- 2400
NB volt - 1.15

(have also tried back at stock.... still same problems)

W/C: XSPC Rasa 750 - rx240 (4x push/pull - Scythe Gentle Typhoon Ap-15)
RAM: G.Skill 2x4Gb 1600Mhz 9-9-9-24

GPU: Asus R9 270x DCII Top edition - stock: 1120/5600 - latest bios & latest beta drivers
(have also tried every driver from 13.9 onwards... no change..... no differnece if using mantle or dx11)

SSD: Samsung EVO 250Gb - latest firmware version/bios
HDD: Samsung HD501LJ Sata2 500Gb
Mouse: Logitech G400
Keyboard: standard
Headphones: Sennheiser HD558
Monitor: Acer V273HL

TP-Link Archer D7 1750AC modem/router - net connection - 6Mbps downstream, 1Mbps upstream (Australian ADSL2+)

default origin, chrome browser,



1. fps drop from above 70 fps to below 40fps (max) with drops down to less then 10fps at random times.

2. micro stuttering & rubber banding - consistent throughout but worse when levaloution of lots of explosions/on screen activity happening

I've tried everything including wiping the entire PC, reinstalling the basics & updating. - no change apart from wasting alot of my monthly internet allowance (once again crap Aus internet plans)

the only thing thats kinda of helped was -

A. disabling the following in bios

CPU Acttive Core Control
AMD Turbo Core Technology
AMD IO C-State Technology
Cool'n'Quiet
Secure Virtual Machine
Enhanced Halt State (C1E)

B. go into AMD Catalyst Control Centre >> Gaming >> 3D application settings >> tessellation mode. Change this from AMD Optimised to "use application settings"

doing the all that raised the average fps a bit to an average of 56-60fps on mantle.....but no where near as good as it was.... but still mirco stutter, and random fps drops to 25fps.

the problem seems worse if PC has woken up from a sleep..... i need to do cold boot and then play.
Grototech
AU Enlisted: 2012-11-06
2014-07-30 09:49
Fx8350 4.5ghz
Asus sabertooth990 2.0
16gb 1866mhz ram
1000w psu
watercooled
Msi gtx780sli
Ssd 120g samsung
windows 8.1

340.50 driver


game ran well before the last patch. And even better before origin update. I have done all the fixes etc.

Before update
In sli fps were locked at 140 on on my asus 144mhz monitor. Never dipped below. Uncapped would range arou d the 160 mark.
in single card mode it would run between 70-90 depending on map. But still smooth.

origin updated
in sli and single card mode got a very slight stutter no matter what settings. Even with overlay etc off

july 8th patch.
sli unplayable. Cant hold 140fps anymore. Stutter is the worst i have seen in a game. Siege and dt are the worst but all perform bad.

singlecard my fps are down to 55-70 but stutter is no where near as bad as sli. Altho its still very noticable.
Fe_DanAkaPharao
SE Enlisted: 2013-07-01
2014-07-30 10:10
1. Frame drops on most maps at certain points.
2. DT maps seem to have more issues with much larger drops
3. Freezing of player when sprinting or shooting, it just stops and you have to relase button and push it again.
4. Crashing with both BF4.exe fail and the directX error
5. The revive bug has gotten worse on all maps, corpses sometimes dissapear from certain angles

Win 8.1, i7 4770K, GTX760 SLI, 2Gb 16Gb RAM, Nvidia driver 340.52, Chrome and latest version or Origin 9.4.12.2807 - 291224
Phantom - the chase is always better than the catch https://www.youtube.com/channel/UCCW2DIVEuczg_FYIKiWXVzQ/videos
THISaint
GE Enlisted: 2011-10-27
2014-07-30 10:18
I'm glad you guys are posting threads like this! :)
Not an official representative.
EquaI1ty-UA
UA Enlisted: 2013-12-26
2014-07-30 10:39
1. Freezing my character. Lasts, on average, a few seconds. And than it`s "teleport" you.

Origin 9.4.12.2807-291224
Google Chrome and Opera latesr versions.
NVidia 340.52
Windows 8.1

Reinstalling the game and the Origin does not solve this problem.
It started after few days when Dragon Teeth was released.

PS: sorry for my bad english.
Intel Core i7 4770K+Corsair H110, ASUS Maximus VI Hero, G.Skill F3-2600C10Q-16GTXD (4х4Gb, 2600MHz), MSI GTX 780 Gaming (N780 TF 3GD5/OC) + NZXT Kraken G10 + Zalmal LQ315 + 2xNoctua NF-F12-PWM, Seasonic X-750 GOLD, Samsung 840 Pro 256 Gb, WD Black WD5003AZEX, WD Red WD30EFRX, Cooler Master Cosmos II
Rafffl
Enlisted: 2011-12-23
2014-07-30 10:51
AMD phenom II X6 1090 T processor ( 6 cpu ) - 3.2Ghz
GTX 560 ti 1232 Mb
16Gb RAM
Direct X version 11.
SSD or HDD ( not tried the game on the SSD)

-We're looking for details like:
-Windows version, Driver versions, Direct-X dumps, Settings files, Origin version, web browser etc.

Windows 7 PRO fully updated , latest nvidia drivers (340.52) , latest Origin version , latest Mozilla Firefox version.

-We need to know:
-What server, Map, When issues started (do they start during the same part of a game?), as much details as you can think of.

All the servers , no differences between each servers. Flood zone and Shanghai , All Dragon's Teeth maps especially Pearl Market ( The FPS are really low on this map compared to the others map , but it's more noticiable when you are on rooftops , it become impossible to play). 64 Players is impossible , 42 is ok.
Normally I score a number of 60 FPS and more on all maps ( other than Flood Zone , Shanghai , and Dragon teeth maps) but on Pearl Market , I struggle to get 35 fps.
No probs with CR , SA , NS and the other base game maps.

-We also need to know:
-What you have tried - did you reinstall the game, change drivers, tweak settings, or if you are running some special user.cfg file.

Tried to set all in LOW , at least 10 more fps than HIGH( weird ? ), tried also the reduce de resolution scale to the minimum(5%) , I get the same amount of fps than if my resolution scale was at 100% ( Exactly the same.) Tried to install other drivers , no noticiable differences. And tried to change my user.cfg with Battlefield 4 Setting Editor , can't see change with advanced options disabled or not.

I have the feel that the game , with each update become more and more intensive for my pc , and with the bad netcode , which is back , is terribly frustrating.
To be honest I feel that the game is as the same state as the release of the game ( instable ).
It's a shame , because BF3 was perfectly fluid ( High , medium settings with 100+ fps ) and more pretty than BF4.

I can send others info if asked.
Alph4Dawg
HR Enlisted: 2011-10-25
2014-07-30 11:12
http://i.gyazo.com/e4f4eae3ca53bb7b9d997753b385609b.png [i.gyazo.com]

These are my PC specs.Playing using Mantle renderer enabled as it's unplayable to me using DirectX.
Using DirectX I have massive FPS drops (50-60 FPS drop from 100+ for no reason, after round or two game is completely unplayable).
Using Mantle my FPS is stable but I also experience FPS drop, just not that massive as while using DirectX (20-30 FPS drop here and there) but game stutters often for no reason.
I've noticed it stutters when chat is full and every time new message pops out, game starts to stutter and there's FPS drop.
First round I can play without problems, but every round after that there's stutter and FPS drop occasionally.When I join new server and game starts from the scratch it's all fine again but problems with FPS drop and stutter start to appear again after couple of rounds.
Dragon's Teeth; every 3rd or 4th round there's massive FPS drop from 100+ FPS to 20, 30, 40, 50 FPS and it won't go above 60 FPS for some reason.
Joining new server fixes it but problem occurs once again after few rounds.

Stutter is the main problem and it's a real issue that bothers me at most.Most of the time gameplay is not smooth and while it stutters there's lag occasionally, plus I have to press 'R' to reload 2-3 times in a row to perform a clean and proper reload, character movements are floppy, etc.

Playing on 1080P @ LOW.Everything is set at low.
My FPS remains the same at LOW, MED, HIGH but I thought setting everything to low would fix the stutter but it didn't.

Using 14.4 drivers as new BETA's bring no performance increase + with latest BETA drivers I've experienced couple of BSOD's.

Using this config file as without it game performs even worse:

WorldRender.TransparencyShadowmapsEnable 0
WorldRender.MotionBlurEnable 0
WorldRender.MotionBlurQuality 0
WorldRender.MotionBlurMaxSampleCount 0
WorldRender.SpotLightShadowmapEnable 0
WorldRender.LightTileCsPathEnable 0
PostProcess.DynamicAOEnable 0
PerfOverlay.DrawFps 1
WorldRender.PlanarReflectionEnable 0


Please fix it.

Best regards,

A4D
Dipso
NO Enlisted: 2011-10-24
2014-07-30 11:19
Fire Effects Cause severe performance loss on my Geforce 780GTX

I can run the game fine with all settings on ultra, but whenever there are fire effects (Especially on fire storm but also the burning cars on siege of shanghai) it drops the fps drastically unless i sett effects to high. (I still get frame loss when i lower that setting but it atleast stays playable.)

There is definately something about how these are rendered that causes a disproportionate amount of frame loss.

I have experienced this issue across several iterations of drivers from NVIDIA, including latest Drivers.
"imperio mundi per papyrione callidus uti"
Froyo0
RO Enlisted: 2013-10-06
2014-07-30 11:24
Windows 8.1, hd 7770, catalyst 14.4, i3 3220, dx 11.1, no cfg file, 4gb RAM DDR3.

Problem: even on low settings when i look fast behind me it stutters(first a big cpu spike and very next a gpu spike).
Lt_BAD-DOG
PL Enlisted: 2013-03-15
2014-07-30 11:41
I'm not sure if it was mentioned here but "Pearl Market" is really badly optimized. On some parts of the map (probably when there's a lot of destruction going on) my frames drop from 55-70 to 30-40.
This is the only map that drives my PC into that low FPS and I heard a couple of people complaining about this map and low FPS as well.
SaanHolo
AU Enlisted: 2012-10-30
2014-07-30 11:42
@T1gge, I get DirectX errors if I overclock my graphics card to above 1110MHz, it's something like "DirectX function "GetDeviceRemovedReason" or something, but if I stay under 1110MHz, I never get any DX errors.
theradgamerdan - http://youtube.com/theradgamerdan
TeamSpirit1
IN Enlisted: 2013-04-10
2014-07-30 12:05
1. Since last patch , Game stutters and freezes during gunfights especially when i am under fire.
2. Experiencing crashes to desktop without any error.
3. Netcode was improved after 30 hz update. But since last patch , i am dying behind cover a lot.


Tried repairing game , reinstalling directx , updating graphic card driver but no use. My system specs - Windows 8.1 , gtx 660 , 8gb ram , i5-3770k processor.
Thotaz
DK Enlisted: 2011-10-26
2014-07-30 12:30
When the hotel sides collapse on hainan resort the FPS will sometimes drop very low (less than 30) and stutter. It doesn't happen every time, and sometimes the drop only lasts for 2 seconds, instead of the 5 seconds. Also it doesn't seem to be a server problem, because some people will report FPS drops while I stay at my capped 90 FPS without any drops at all.

Finally it's definitely a game problem, because it even happens on closed platforms with identical setups like the consoles, but if you really want to know my specs then here you go:

Windows versions: 8 and 8.1
Driver versions: Any driver since release up to now
Settings: Seems to happen regardless of what settings I have, because I've tried a lot of different settings in the past few months
CPU: 2500k @ 4.2 and 4.5GHz
GPU: GTX 570 and 770
RAM: 8GB
Drive that it's running off: 840 evo SSD with 250GB

In case it's not clear I've done some changes to my system throughout these months, that's why I list more than one thing like the 570 and 770 example.

I'm also having a problem with the naval strike maps sometimes stuttering but I don't really have any details about this, I might do some tests and come back later with info about this.
SaanHolo
AU Enlisted: 2012-10-30
2014-07-30 12:33
Thotaz said:
When the hotel sides collapse on hainan resort the FPS will sometimes drop very low (less than 30) and stutter. It doesn't happen every time, and sometimes the drop only lasts for 2 seconds, instead of the 5 seconds. Also it doesn't seem to be a server problem, because some people will report FPS drops while I stay at my capped 90 FPS without any drops at all.

Finally it's definitely a game problem, because it even happens on closed platforms with identical setups like the consoles, but if you really want to know my specs then here you go:

Windows versions: 8 and 8.1
Driver versions: Any driver since release up to now
Settings: Seems to happen regardless of what settings I have, because I've tried a lot of different settings in the past few months
CPU: 2500k @ 4.2 and 4.5GHz
GPU: GTX 570 and 770
RAM: 8GB
Drive that it's running off: 840 evo SSD with 250GB

In case it's not clear I've done some changes to my system throughout these months, that's why I list more than one thing like the 570 and 770 example.

I'm also having a problem with the naval strike maps sometimes stuttering but I don't really have any details about this, I might do some tests and come back later with info about this.


Omg I have the exact same ssd as you samsung 840 evo 250gb
theradgamerdan - http://youtube.com/theradgamerdan
cc_Siege
BG Enlisted: 2012-11-05
2014-07-30 12:33
- General performance (45-100 fps)
- CPU stutters (little from time to time)
- Crashes (once for the last few months)

System Specs:

Motherboard: AsRock P67 Pro
GPU: Gigabyte R9 270x
CPU: Intel Core I5-3350p
RAM: 8GB g.skill (dual channel)
HDD:Western Digital 500 GB 7200RPM
PS:650W Fortron HEXA
OS:Windows 8.1 64-bit
AMD Driver Version:14.6(beta)

I play Battlefield 4 on all High settings with 110 FOV on a 1440x900 resolution

When i stutter its usually random and if I stutter its really not so bad yet its unplesent.

My biggest problem with the game is the loading times.
When i load up a map first its really slow,after that all my weapons gadgets etc, the kits essencially are blank(they are still loading)
And if i click deploy I am unarmed and I can get killed without a change of retaliation cuz my stuff is still loading... yet I was loading the map for the past 3 or 5 minutes if its gonna load so long why does it not load everything.
Aside from that sometimes I dont have sound and my textures are still loading and are really low quality and there is really bad poppin.
Durring this time I usually get really high stuttering and weird animation error eg: when I am driving a tank it starts to shake and feel unnatural.
After everything finally loads lets say 1,2 minutes later , the game Run's fine looks great I have great sound and everything.

If these things can be fixed up i will be grateful, also anything that can make my FPS a little more stable will be welcome, the range from 45 to 100-120ish is really big of a gap, I would love to have a minimum of 60. Also i would want to point out reducing the graphics on my machine does not give me that much of a performance boost for some reason so i play on high settings, Only ultra i start to dip to a minimum for 40-35 so I avoid it.

Sorry for my bad English it's not my native language.
mlndbomb
US Enlisted: 2013-11-29
2014-07-30 12:43
windows 7 sp1, catalyst 14.7, mantles api, chrome. core i7 965, 12gb ram, and r9 270 is the hardware.

On hainan resort, if the main building's sides collapse, this results in low fps for clients, and sometimes results in permanent rubber banding for everyone on the server for the remaining length of the match.
LoApls
SE Enlisted: 2011-10-27
2014-07-30 12:49
Problem: My game freezes randomly for a few seconds following with a crash. Sometimes I have to close bf4.exe myself.

Something that MIGHT trigger my freeze/crash is that I usually spam TAB (scoreboard) when I die, or just randomly when I'm running around. The game has frozen a couple of times right after I've "spammed" my TAB button 3-4 times.

Specs:

OS: Windows 8.1 64-bit (KB2980654)

Mobo: Asus Sabertooth Z77 (newest bios and drivers)
RAM: Corsair 8GB XMS3 @ stock
GPU: Gigabyte GTX670 Windforce 3x OC @ stock
CPU: Intel i5 3570k @ 4,3 GHz, stability tested with AIDA64 for 24 hours with a maximum temperature of 71°C. (watercooled with corsair)
SSD where BF4 is installed: Samsung SSD 840 EVO 250GB

I have had these exact problems a number of times during BF4's lifecycle. Before the Dragon's teeth patch my game ran resonably stable with only a crash every ~50 rounds, after the DT patch my game has been freezing/crashing almost every round after ~20 minutes, and if I tried to rejoin the same server the crash would occur much sooner than usual, something around 5-10 minutes.

What I have done to troubleshoot my issue is:

Rolled back my Nvidia drivers from 337.88 WHQL to 335.23 WHQL with no results.

Updated to 335.23 WHQL again with no results.

Updated to 340.52 WHQL with no results.

Turned off origin in-game overlay with no results.

Updated Origin to Origin Beta with no results.

Updated punkbuster via PBSetup with no results.

Updated Directx via DXSetup from my BF4 folder with no results.

Installed Windows 8.1 on a separate empty SSD with BF4 and the software needed to run BF4 properly, with no results.

I have just recently completely wiped my nvidia drivers with "Display Driver Uninstaller" properly (in safe mode etc.) and installed nvidia's new 340.52 WHQL drivers without Geforce Experience. I have yet to test the game with this as I did this yesterday so I will update my post with results later.
 
Thread is locked.
Thread is locked.